summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatatahooligan2022-09-22 22:09:49 +0300
committerpatatahooligan2022-09-22 22:09:49 +0300
commit4fd74a13b2bd56b0a053b1ac8fb925b962e9d106 (patch)
tree3fb7968eae2517514f49d46b57621407c7b2094b
downloadaur-4fd74a13b2bd56b0a053b1ac8fb925b962e9d106.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c66130c36a1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cppfront-git
+ pkgdesc = Experimental and incomplete compiler for proposed C++ 'syntax 2'
+ pkgver = r250.5b100f6
+ pkgrel = 1
+ url = https://github.com/hsutter/cppfront
+ arch = x86_64
+ license = CCPL
+ makedepends = gcc
+ makedepends = git
+ source = git+https://github.com/hsutter/cppfront.git
+ md5sums = SKIP
+
+pkgname = cppfront-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cf2489a8799
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Filon Oikonomou <filwn.oikonomou at gmail dot com>
+
+_pkgnamebase=cppfront
+pkgname=${_pkgnamebase}-git
+pkgver=r250.5b100f6
+pkgrel=1
+pkgdesc="Experimental and incomplete compiler for proposed C++ 'syntax 2'"
+arch=('x86_64')
+url='https://github.com/hsutter/cppfront'
+license=('CCPL')
+makedepends=(
+ 'gcc'
+ 'git')
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${_pkgnamebase}"
+
+ # As of writing this, there are no tags or official releases
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgnamebase}/source/"
+ g++ cppfront.cpp -o cppfront -std=c++20
+}
+
+package() {
+ install -Dm755 "$srcdir/${_pkgnamebase}/source/cppfront" \
+ -t "$pkgdir/usr/bin/"
+
+ install -Dm755 "$srcdir/${_pkgnamebase}/include/cpp2util.h" \
+ -t "$pkgdir/usr/include/"
+}