summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2022-12-29 22:03:17 +0100
committerMichał Walenciak2022-12-29 22:03:17 +0100
commit0cb6fffdfa42c76a3bc34125b0711bc81a691513 (patch)
tree6b760d4717214cd89a15638cf66fcf2812401885
downloadaur-0cb6fffdfa42c76a3bc34125b0711bc81a691513.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5c9776d98a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cppgraphqlgen
+ pkgdesc = Set of GraphQL libraries and tools
+ pkgver = 4.5.0
+ pkgrel = 1
+ url = https://github.com/microsoft/cppgraphqlgen
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = pegtl
+ makedepends = rapidjson
+ depends = boost-libs
+ source = https://codeload.github.com/microsoft/cppgraphqlgen/tar.gz/v4.5.0
+ md5sums = 45b0994a06acd0a2602b2bca126f897b
+
+pkgname = cppgraphqlgen
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4551810ee04d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Michał Walenciak <kicer86@gmail.com>
+pkgname=cppgraphqlgen
+pkgver=4.5.0
+pkgrel=1
+pkgdesc="Set of GraphQL libraries and tools"
+arch=('i686' 'x86_64')
+url="https://github.com/microsoft/cppgraphqlgen"
+license=('MIT')
+groups=()
+depends=('boost-libs')
+makedepends=('cmake'
+ 'pegtl'
+ 'rapidjson')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://codeload.github.com/microsoft/$pkgname/tar.gz/v$pkgver)
+noextract=()
+md5sums=('45b0994a06acd0a2602b2bca126f897b')
+
+build()
+{
+ cd $pkgname-$pkgver
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=None -Wno-dev ..
+ make
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+ cd build
+ make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/bin/$pkgname/* $pkgdir/usr/bin/
+ rm -fr $pkgdir/usr/bin/$pkgname
+}
+