summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2019-06-19 22:02:54 +0200
committerIlias Stamatis2019-06-19 22:02:54 +0200
commit40179b8993d9ece94944196914bd048cccbbdf57 (patch)
treece54cd57a54437967ac7c422d6c5162bedbc9f3f
downloadaur-40179b8993d9ece94944196914bd048cccbbdf57.tar.gz
initial commit - version 1.18
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..887ac108241a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cppi
+ pkgdesc = GNU Cppi indents C preprocessor directives to reflect their nesting, among other regularizations.
+ pkgver = 1.18
+ pkgrel = 1
+ url = https://www.gnu.org/software/cppi/
+ arch = any
+ license = GPL3
+ depends = gawk
+ source = https://ftp.gnu.org/gnu/cppi/cppi-1.18.tar.xz
+ md5sums = 720f4e442287283a02979ba43a44366e
+
+pkgname = cppi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f8ae100c355
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+cppi-1.18-1-any.pkg.tar.xz
+cppi-1.18.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0d2a0a3b5ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+
+pkgname=cppi
+pkgver=1.18
+pkgrel=1
+pkgdesc="GNU Cppi indents C preprocessor directives to reflect their nesting, among other regularizations."
+arch=(any)
+url="https://www.gnu.org/software/cppi/"
+license=('GPL3')
+depends=('gawk')
+source=("https://ftp.gnu.org/gnu/cppi/cppi-${pkgver}.tar.xz")
+md5sums=('720f4e442287283a02979ba43a44366e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}