summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Marchi2023-12-05 11:02:04 -0500
committerSimon Marchi2023-12-05 11:03:02 -0500
commitb06b93ac548cf92d4ae926cedeec80a62fa505d9 (patch)
tree5648e9aa302201b1ef57d7a6731685e30d472286
downloadaur-b06b93ac548cf92d4ae926cedeec80a62fa505d9.tar.gz
Initial version
Inspired by cppinsights-git [1]. [1] https://aur.archlinux.org/packages/cppinsights-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73cd281b5939
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cppinsights
+ pkgdesc = C++ Insights - See your source code with the eyes of a compiler
+ pkgver = 0.10
+ pkgrel = 1
+ url = https://cppinsights.io
+ arch = x86_64
+ license = MIT
+ makedepends = ninja
+ depends = llvm-libs
+ depends = llvm
+ depends = clang
+ conflicts = cppinsights-git
+ source = https://github.com/andreasfertig/cppinsights/archive/refs/tags/v_0.10.tar.gz
+ b2sums = b0e48cd3d95556d48b84333c16cd20b282c8fe77d29f422961f9d89ad5858a32c4878ee7236a821e03f4b5523bb21987085a6cdd8bb052e9585688c646e8bc39
+
+pkgname = cppinsights
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..598eb5d917b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Simon Marchi <simon.marchi at polymtl dot ca>
+# Contributor: inhzus <inhzus at gmail dot com>.
+pkgname=cppinsights
+pkgver=0.10
+pkgrel=1
+pkgdesc="C++ Insights - See your source code with the eyes of a compiler"
+arch=('x86_64')
+url="https://cppinsights.io"
+license=('MIT')
+depends=(llvm-libs llvm clang)
+makedepends=('ninja')
+conflicts=("cppinsights-git")
+source=("https://github.com/andreasfertig/cppinsights/archive/refs/tags/v_0.10.tar.gz")
+b2sums=('b0e48cd3d95556d48b84333c16cd20b282c8fe77d29f422961f9d89ad5858a32c4878ee7236a821e03f4b5523bb21987085a6cdd8bb052e9585688c646e8bc39')
+
+build() {
+ cd "${srcdir}/${pkgname}-v_${pkgver}"
+ cmake -G"Ninja" -B build -DCLANG_LINK_CLANG_DYLIB=1 -DLLVM_LINK_LLVM_DYLIB=1 -DINSIGHTS_USE_SYSTEM_INCLUDES=OFF .
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-v_${pkgver}/build"
+ install -Dm755 "insights" "${pkgdir}/usr/bin/insights"
+}
+
+