summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2024-06-10 07:02:14 +0000
committerGitHub Action2024-06-10 07:02:14 +0000
commit5e5ca95f5dc09524c369f26f3cd2085a06a512b3 (patch)
treeedac5279383ff3489791c08c4285371c6e99d1fb
parent1018b2e87c9000d75cda62b829033fdcf219766d (diff)
downloadaur-5e5ca95f5dc09524c369f26f3cd2085a06a512b3.tar.gz
Update from GitHub Actions: cppman-git: bump to 0.5.6.r5.ga3f3846
https://github.com/RiverOnVenus/AUR-packages/actions/runs/9443856988
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rw-r--r--setup.py.patch13
3 files changed, 31 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 334d4f052dbb..87ddf11021a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cppman-git
- pkgdesc = C++ 98/11/14 manual pages for Linux/MacOS
- pkgver = 0.5.3.r2.g5b39e69
+ pkgdesc = C++ 98/11/14/17/20 manual pages for Linux, with source from cplusplus.com and cppreference.com.
+ pkgver = 0.5.6.r5.ga3f3846
pkgrel = 1
url = https://github.com/aitjcize/cppman
arch = any
@@ -10,14 +10,15 @@ pkgbase = cppman-git
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ depends = bash
+ depends = python
depends = python-beautifulsoup4
depends = python-html5lib
- optdepends = vim: Pager option
- provides = cppman=0.5.3
+ optdepends = vim: For using vim as a pager
+ optdepends = perl: for bash/zsh completion
+ provides = cppman
conflicts = cppman
- source = cppman::git+https://github.com/aitjcize/cppman
- source = setup.py.patch
+ source = cppman-git::git+https://github.com/aitjcize/cppman
sha256sums = SKIP
- sha256sums = 525deb610fae6c6222164154c34c3290663bcd522b339c659f338f2cbc120033
pkgname = cppman-git
diff --git a/PKGBUILD b/PKGBUILD
index 43e32f07531c..e80d0ca8db01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: RiverOnVenus <error@zhui.dev>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Wei-Ning Huang <aitjcize@gmail.com>
pkgname=cppman-git
-_pkg="${pkgname%-git}"
-pkgver=0.5.3.r2.g5b39e69
+pkgver=0.5.6.r5.ga3f3846
pkgrel=1
-pkgdesc="C++ 98/11/14 manual pages for Linux/MacOS"
+pkgdesc="C++ 98/11/14/17/20 manual pages for Linux, with source from cplusplus.com and cppreference.com."
arch=('any')
url='https://github.com/aitjcize/cppman'
license=('GPL3')
-depends=('python-beautifulsoup4' 'python-html5lib')
-optdepends=('vim: Pager option')
+depends=('bash' 'python' 'python-beautifulsoup4' 'python-html5lib')
+optdepends=(
+ "vim: For using vim as a pager"
+ "perl: for bash/zsh completion"
+ )
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-provides=("$_pkg=${pkgver%.r*}")
-conflicts=("$_pkg")
-source=("$_pkg::git+$url"
- 'setup.py.patch')
-sha256sums=('SKIP'
- '525deb610fae6c6222164154c34c3290663bcd522b339c659f338f2cbc120033')
+provides=('cppman')
+conflicts=('cppman')
+source=("$pkgname"::"git+${url}")
+sha256sums=('SKIP')
pkgver() {
- git -C "$_pkg" describe --long --tags | sed 's/-/.r/;s/-/./'
+ cd $pkgname
+ git describe --long --tags --abbrev=7 | sed 's/-/.r/;s/-/./'
}
-prepare() {
- patch -p1 -d "$_pkg" < setup.py.patch
+prepare(){
+ cd $pkgname
+ git clean -dfx
}
build() {
- cd "$_pkg"
- python -m build --wheel --no-isolation
+ cd $pkgname
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_pkg"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ cd $pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 "$srcdir/$pkgname/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/setup.py.patch b/setup.py.patch
deleted file mode 100644
index 4f8768397cb4..000000000000
--- a/setup.py.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 350e6ae..ac0da87 100644
---- a/setup.py
-+++ b/setup.py
-@@ -9,7 +9,7 @@ _package_data = [
- ]
-
- _data_files = [
-- ('share/doc/cppman', ['README.rst', 'AUTHORS', 'COPYING', 'ChangeLog']),
-+ ('share/doc/cppman', ['README.rst']),
- ('share/man/man1', ['misc/cppman.1']),
- ('share/bash-completion/completions', ['misc/completions/cppman.bash']),
- ('share/zsh/vendor-completions/', ['misc/completions/zsh/_cppman'])