summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-10-22 17:06:30 +0200
committerMichal Wojdyla2021-10-22 17:06:30 +0200
commitc4fec23d927ac0f5c2a527b572e04166d7b9781e (patch)
tree73102304c41bda55e242d7e5dd86e91dddc90362
parent4238ba9fb882cec8397d424e99c5740b36134b11 (diff)
downloadaur-cppmicroservices-git.tar.gz
update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2040b96a2a9d..08d8ed6ce041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cppmicroservices-git
pkgdesc = The C++ Micro Services library provides a dynamic service registry and module system, partially based the OSGi Core Release 5 specifications.
- pkgver = v2.1.1.r0.g13080ed
+ pkgver = 3.0.0.r369.g4635f63f
pkgrel = 1
- url = https://github.com/saschazelzer/CppMicroServices
+ url = https://github.com/CppMicroServices/CppMicroServices
arch = i686
arch = x86_64
license = custom: Apache2.0
@@ -11,8 +11,9 @@ pkgbase = cppmicroservices-git
depends = gcc-libs
provides = cppmicroservices
conflicts = cppmicroservices
- source = cppmicroservices::git://github.com/saschazelzer/CppMicroServices.git
+ source = cppmicroservices::git+https://github.com/CppMicroServices/CppMicroServices.git
+ source = git+https://github.com/boostorg/nowide.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = cppmicroservices-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3e7eb7a61a4a..c47ead3ee508 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
-# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
-# Contributor:
+# Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=cppmicroservices-git
-pkgver=v2.1.1.r0.g13080ed
+pkgver=3.0.0.r369.g4635f63f
pkgrel=1
pkgdesc="The C++ Micro Services library provides a dynamic service registry and module system, partially based the OSGi Core Release 5 specifications."
arch=('i686' 'x86_64')
-url="https://github.com/saschazelzer/CppMicroServices"
+url="https://github.com/CppMicroServices/CppMicroServices"
license=('custom: Apache2.0')
depends=('gcc-libs')
makedepends=('git' 'cmake')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=('cppmicroservices::git://github.com/saschazelzer/CppMicroServices.git')
-md5sums=('SKIP')
+source=('cppmicroservices::git+https://github.com/CppMicroServices/CppMicroServices.git'
+ 'git+https://github.com/boostorg/nowide.git')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "${pkgname%-*}"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+prepare() {
+ cd "${pkgname%-*}"
+ git config submodule.third_party/boost/nowide.url $srcdir/nowide
+ git submodule update
}
build() {