summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bailey2017-10-15 21:05:20 -0400
committerEric Bailey2017-10-15 21:05:20 -0400
commitd1ee25d183d413eb8e2865ed230403345f7faa0a (patch)
treed5bc376ef080349f55693251fe9f53f4739aba63
parentb7d3a80d916802f3246f25652b6b1647b2fede70 (diff)
downloadaur-d1ee25d183d413eb8e2865ed230403345f7faa0a.tar.gz
Fix cppo binary not being installed with rest of files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1349af513b3..d7d3306b4ebf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 7 12:14:59 UTC 2017
+# Mon Oct 16 01:05:00 UTC 2017
pkgbase = cppo
pkgdesc = The C preprocessor written in OCaml
pkgver = 1.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://mjambon.com/cppo.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d1caeb5345e1..e68c92e84e4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=cppo
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="The C preprocessor written in OCaml"
arch=('i686' 'x86_64' 'armv7h')
license=('BSD')
@@ -25,5 +25,7 @@ package() {
opam init -n
mkdir -p "${pkgdir}/usr/bin" "$pkgdir$(ocamlfind printconf destdir)"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- make install BINDIR="${pkgdir}/usr/bin"
+ make install
+ cd _build/install/default/bin
+ install -m755 -t ${pkgdir}/usr/bin cppo
}