summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-04 12:16:21 +0200
committerJakob Gahde2019-09-04 12:17:13 +0200
commitf9870d5b15100bd65284a689c78d4e3e7a37e4dc (patch)
treed19bd278b58b0549fa8deef0615a21773287b84b
parent8f91214a961523167d4dfc75911525815587dee3 (diff)
downloadaur-f9870d5b15100bd65284a689c78d4e3e7a37e4dc.tar.gz
cppo 1.6.6-1: Update to new version
Based on the version that was recently dropped from [community]
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 31 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d483ccd3b17..a071cb7ac939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Jan 25 22:59:13 UTC 2018
pkgbase = cppo
- pkgdesc = The C preprocessor written in OCaml
- pkgver = 1.6.1
+ pkgdesc = C-style preprocessor for OCaml
+ pkgver = 1.6.6
pkgrel = 1
- url = https://github.com/mjambon/cppo
- arch = i686
+ url = https://github.com/ocaml-community/cppo
arch = x86_64
- arch = armv7h
license = BSD
- makedepends = jbuilder
- makedepends = ocaml-findlib
+ makedepends = dune
makedepends = ocamlbuild
- makedepends = clingo
- makedepends = python2
depends = glibc
- source = https://github.com/mjambon/cppo/archive/v1.6.1.tar.gz
- sha256sums = 0e93522c5e51a9433fc2327f33ebc56f66beee7abaacab8d98de57591a0626e6
+ optdepends = ocamlbuild: ocamlbuild plugin
+ source = https://github.com/ocaml-community/cppo/releases/download/v1.6.6/cppo-v1.6.6.tbz
+ sha512sums = 44ecf9d225d9e45490a2feac0bde04865ca398dba6c3579e3370fcd1ea255707b8883590852af8b2df87123801062b9f3acce2455c092deabf431f9c4fb8d8eb
pkgname = cppo
diff --git a/PKGBUILD b/PKGBUILD
index 9ae7447d6b89..ff20f4c96a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
-# Maintainer: Leonard de Ruijter <dev@systeemdenker.nl>
-# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
-# Contributor: Justin Davis <jrcd 83 at gmail>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Bruno Pagani <archange@archlinux.org>
pkgname=cppo
-pkgver=1.6.1
+pkgver=1.6.6
pkgrel=1
-pkgdesc="The C preprocessor written in OCaml"
-arch=('i686' 'x86_64' 'armv7h')
+pkgdesc="C-style preprocessor for OCaml"
+arch=('x86_64')
+url="https://github.com/ocaml-community/cppo"
license=('BSD')
depends=('glibc')
-makedepends=('jbuilder' 'ocaml-findlib' 'ocamlbuild' 'clingo' 'python2')
-url="https://github.com/mjambon/cppo"
-source=("https://github.com/mjambon/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('0e93522c5e51a9433fc2327f33ebc56f66beee7abaacab8d98de57591a0626e6')
+optdepends=('ocamlbuild: ocamlbuild plugin')
+makedepends=('dune' 'ocamlbuild')
+source=("https://github.com/ocaml-community/cppo/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tbz")
+sha512sums=('44ecf9d225d9e45490a2feac0bde04865ca398dba6c3579e3370fcd1ea255707b8883590852af8b2df87123801062b9f3acce2455c092deabf431f9c4fb8d8eb')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make all
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+
+ dune build
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+
+ dune runtest
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- export OPAMROOT="${srcdir}/.opam"
- opam init -n
- mkdir -p "${pkgdir}/usr/bin" "$pkgdir$(ocamlfind printconf destdir)"
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm755 $OCAMLFIND_DESTDIR
- cd _build/install/default/bin
- install -m755 -t ${pkgdir}/usr/bin cppo
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+
+ dune install --destdir="${pkgdir}"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}