summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgdgsc2018-01-30 11:37:14 +0800
committerxgdgsc2018-01-30 11:46:38 +0800
commitc945758e241be6c8b4c9853778e679653d2e1324 (patch)
treed34044673aed1a236a5ee294ba1d10914f00ff04
parentf7cd7e4721a202706402454d179f6c2b55528ad8 (diff)
downloadaur-c945758e241be6c8b4c9853778e679653d2e1324.tar.gz
upd
i#upd
-rw-r--r--.SRCINFO10
-rw-r--r--17a198081379384ed9373828f905592ce9c4bdf3.patch25
-rw-r--r--PKGBUILD13
3 files changed, 41 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 724212eba3f8..f736defc9d71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 22 03:20:29 UTC 2017
+# Tue Jan 30 03:39:25 UTC 2018
pkgbase = cpprestsdk
pkgdesc = A cross-platform, modern, and asynchronous library that enables developers to access and author connected applications
- pkgver = 2.10.0
+ pkgver = 2.10.1
pkgrel = 1
url = https://github.com/Microsoft/cpprestsdk/
arch = i686
@@ -14,8 +14,10 @@ pkgbase = cpprestsdk
depends = openssl>=1.0.0
conflicts = casablanca
conflicts = casablanca-git
- source = cpprestsdk-2.10.0.tar.gz::https://github.com/Microsoft/cpprestsdk/archive/v2.10.0.tar.gz
- sha512sums = 78e7a38c21db5b563d08cb082bfa96360ac44c66f2189a614d3d2bb71655fd82d931f138590d2dba2d6a4c0884ae37a5be34ea3b753c3517bd68ce490daf60b4
+ source = cpprestsdk-2.10.1.tar.gz::https://github.com/Microsoft/cpprestsdk/archive/v2.10.1.tar.gz
+ source = 17a198081379384ed9373828f905592ce9c4bdf3.patch
+ sha512sums = f6a93e5e87e27db724ccc028326b1dce243617cb0ae0d101b2cea700c4f264c073cb0e8a9d88a14be165e16ef2f1f43a17e49278087bc8cf372e623a1b6a9c47
+ sha512sums = 6d33d9bdbe0fa4353d528fe1c9eb4b7071c8d4de848051675554cec7486bfa97015eabef1d3fcd634ae274c9093ac97e718e212e8e03b20576af34184bad3f4d
pkgname = cpprestsdk
diff --git a/17a198081379384ed9373828f905592ce9c4bdf3.patch b/17a198081379384ed9373828f905592ce9c4bdf3.patch
new file mode 100644
index 000000000000..82e3c004b0b4
--- /dev/null
+++ b/17a198081379384ed9373828f905592ce9c4bdf3.patch
@@ -0,0 +1,25 @@
+From 17a198081379384ed9373828f905592ce9c4bdf3 Mon Sep 17 00:00:00 2001
+From: Robert Schumacher <roschuma@microsoft.com>
+Date: Wed, 3 Jan 2018 14:09:36 -0800
+Subject: [PATCH] Fix warning due to boost 1.66
+
+---
+ Release/include/pplx/threadpool.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Release/include/pplx/threadpool.h b/Release/include/pplx/threadpool.h
+index c67db358..db1e97c8 100644
+--- a/Release/include/pplx/threadpool.h
++++ b/Release/include/pplx/threadpool.h
+@@ -67,9 +67,10 @@ class threadpool
+ boost::asio::io_service& service() { return m_service; }
+
+ protected:
+- threadpool(size_t num_threads) : m_service(num_threads) {}
++ threadpool(size_t num_threads) : m_service(static_cast<int>(num_threads)) {}
+
+ boost::asio::io_service m_service;
+ };
+
+ }
++
diff --git a/PKGBUILD b/PKGBUILD
index ada45ba3dd0d..c63fedf34c46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Yang <ohmyarchlinux@gmail.com>
pkgname=cpprestsdk
-pkgver=2.10.0
+pkgver=2.10.1
pkgrel=1
pkgdesc="A cross-platform, modern, and asynchronous library that enables developers to access and author connected applications"
arch=('i686' 'x86_64')
@@ -10,11 +10,15 @@ license=('Apache')
depends=('boost' 'websocketpp' 'openssl>=1.0.0')
makedepends=('cmake>=2.6.0')
conflicts=('casablanca' 'casablanca-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Microsoft/cpprestsdk/archive/v${pkgver}.tar.gz")
-sha512sums=('78e7a38c21db5b563d08cb082bfa96360ac44c66f2189a614d3d2bb71655fd82d931f138590d2dba2d6a4c0884ae37a5be34ea3b753c3517bd68ce490daf60b4')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Microsoft/cpprestsdk/archive/v${pkgver}.tar.gz" "17a198081379384ed9373828f905592ce9c4bdf3.patch")
+sha512sums=('f6a93e5e87e27db724ccc028326b1dce243617cb0ae0d101b2cea700c4f264c073cb0e8a9d88a14be165e16ef2f1f43a17e49278087bc8cf372e623a1b6a9c47'
+ '6d33d9bdbe0fa4353d528fe1c9eb4b7071c8d4de848051675554cec7486bfa97015eabef1d3fcd634ae274c9093ac97e718e212e8e03b20576af34184bad3f4d')
prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}/
+ patch -p1 < ../17a198081379384ed9373828f905592ce9c4bdf3.patch
mkdir -p build
+
}
build() {
@@ -22,6 +26,9 @@ build() {
cmake ../${pkgname}-${pkgver}/Release \
-DBUILD_TESTS=OFF \
-DBUILD_SAMPLES=OFF \
+ -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
+ -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so \
+ -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make -j`nproc`