summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Yang2018-02-06 22:02:02 +0800
committerMichael Yang2018-02-06 22:02:02 +0800
commit069f77b3a5b77c07d5811764e4ddb0d41cb6d502 (patch)
tree07ff7bb7d8b6f51276bf052e628a329eea3417ac
parentb354b61a41e22bd600d8ed5e5aeff3461f8d170f (diff)
downloadaur-069f77b3a5b77c07d5811764e4ddb0d41cb6d502.tar.gz
Update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4d704a237e0..a716b80e3725 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
# Generated by mksrcinfo v8
-# Fri Aug 11 01:16:30 UTC 2017
+# Tue Feb 6 14:01:44 UTC 2018
pkgbase = cpprestsdk-git
- pkgdesc = A cross-platform, modern, and asynchronous library that enables developers to access and author connected applications
- pkgver = 2.9.0.r1852.935917a7
+ pkgdesc = A Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design
+ pkgver = 2.1.0.r1705.g1e4717e5
pkgrel = 1
- url = https://github.com/Microsoft/cpprestsdk/
+ url = https://github.com/Microsoft/cpprestsdk
arch = i686
arch = x86_64
license = MIT
makedepends = git
+ makedepends = boost
makedepends = cmake>=3.0.0
- depends = boost
- depends = websocketpp
- depends = openssl-1.0
+ depends = boost-libs
+ depends = websocketpp-git-dev
+ depends = openssl>=1.0.0
provides = cpprestsdk
conflicts = cpprestsdk
conflicts = casablanca
conflicts = casablanca-git
- source = git://github.com/Microsoft/cpprestsdk.git
+ source = git+https://github.com/Microsoft/cpprestsdk.git
sha512sums = SKIP
pkgname = cpprestsdk-git
diff --git a/PKGBUILD b/PKGBUILD
index 32d53d9c1826..d9c30d2972f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: Michael Yang <ohmyarchlinux@gmail.com>
+# Maintainer: Michael Yang <ohmyarchlinux@protonmail.com>
pkgname=cpprestsdk-git
-pkgver=2.9.0.r1852.935917a7
+pkgver=2.1.0.r1705.g1e4717e5
pkgrel=1
-pkgdesc='A cross-platform, modern, and asynchronous library that enables developers to access and author connected applications'
+pkgdesc='A Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design'
arch=('i686' 'x86_64')
-url='https://github.com/Microsoft/cpprestsdk/'
+url='https://github.com/Microsoft/cpprestsdk'
license=('MIT')
-depends=('boost' 'websocketpp' 'openssl-1.0')
-makedepends=('git' 'cmake>=3.0.0')
+depends=('boost-libs' 'websocketpp-git-dev' 'openssl>=1.0.0')
+makedepends=('git' 'boost' 'cmake>=3.0.0')
conflicts=('cpprestsdk' 'casablanca' 'casablanca-git')
provides=('cpprestsdk')
-source=("git://github.com/Microsoft/cpprestsdk.git")
+source=('git+https://github.com/Microsoft/cpprestsdk.git')
sha512sums=('SKIP')
pkgver() {
cd cpprestsdk
- _ver="$(cat Release/src/CMakeLists.txt | grep -m3 -e CPPREST_VERSION_MAJOR -e CPPREST_VERSION_MINOR -e CPPREST_VERSION_REVISION | grep -o "[[:digit:]]*" | paste -sd'.')"
- echo "$_ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ git describe | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
prepare() {
@@ -27,20 +26,21 @@ prepare() {
build() {
cd build
cmake ../cpprestsdk/Release \
- -DBUILD_TESTS=OFF \
-DBUILD_SAMPLES=OFF \
-DCPPREST_EXPORT_DIR=lib/cmake/cpprestsdk \
- -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
- -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so \
- -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
+check() {
+ cd build
+ make test
+}
+
package() {
make -C build DESTDIR="${pkgdir}" install
cd cpprestsdk
- install -Dm644 license.txt ${pkgdir}/usr/share/licenses/cpprestsdk-git/LICENSE
- install -Dm644 ThirdPartyNotices.txt ${pkgdir}/usr/share/licenses/cpprestsdk-git/ThirdPartyNotices
+ install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/cpprestsdk-git/license.txt
+ install -Dm644 ThirdPartyNotices.txt "${pkgdir}"/usr/share/licenses/cpprestsdk-git/ThirdPartyNotices.txt
}