summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRouven2019-08-04 22:01:53 +0200
committerRouven2019-08-04 22:01:53 +0200
commit7cbde0c52c843db2037e0fc1dee9a4b84e31b5ac (patch)
treefc09ca1f51b04d59beba4a0ceba3f0eb0e1c5b32
downloadaur-7cbde0c52c843db2037e0fc1dee9a4b84e31b5ac.tar.gz
initial commit for cppsplash
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79574dbd34ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cppsplash-git
+ pkgdesc = Changes the background wallpaper for gnome & cinnamon based desktops from the command line.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://gitlab.com/rouvenhimmelstein/cppsplash
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-base
+ depends = qt5-base
+ provides = chwp
+ conflicts = chwp
+ source = https://gitlab.com/rouvenhimmelstein/cppsplash/-/archive/0.0.1/cppsplash-0.0.1.tar.gz
+ sha256sums = d0d3beaab07019d9d356e38689682bc7be4f5fb96dda6bc9847c9557fada950f
+
+pkgname = cppsplash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4113c250c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rouven Himmelstein <rouvenhimmelstein@gmail.com>
+
+_gitname=cppsplash
+_cmdname=chwp
+pkgname=${_gitname}-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Changes the background wallpaper for gnome & cinnamon based desktops from the command line."
+arch=('x86_64')
+url="https://gitlab.com/rouvenhimmelstein/cppsplash"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git' 'cmake' 'qt5-base')
+provides=('chwp')
+conflicts=('chwp')
+source=("https://gitlab.com/rouvenhimmelstein/cppsplash/-/archive/${pkgver}/${_gitname}-${pkgver}.tar.gz")
+sha256sums=('d0d3beaab07019d9d356e38689682bc7be4f5fb96dda6bc9847c9557fada950f')
+
+prepare() {
+ mkdir -p $srcdir/$_gitname-${pkgver}/cmake-build-release
+}
+
+
+build() {
+ cd $srcdir/$_gitname-${pkgver}/cmake-build-release
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname-${pkgver}/cmake-build-release
+ make DESTDIR="$pkgdir" install
+
+ cd ${srcdir}/${_gitname}-${pkgver}
+ install -D -m755 ${_cmdname}.1 ${pkgdir}/usr/share/man/man1/${_cmdname}.1
+} \ No newline at end of file