summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-01-29 17:28:09 -0300
committerRenato Lui Geh2020-01-29 17:28:09 -0300
commit054a8b26b879139270f5856626abb8aff1f54c35 (patch)
tree149249cbbfd094827926ba08ae847d4ceb2d406d
downloadaur-054a8b26b879139270f5856626abb8aff1f54c35.tar.gz
Create PKGBUILD
Signed-off-by: Renato Lui Geh <renatogeh@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..907f4f5fbf70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cppyy-backend
+ pkgdesc = Cling-based Python-C++ bindings (backend)
+ pkgver = 1.10.7
+ pkgrel = 1
+ url = https://cppyy.readthedocs.io/en/latest/index.html
+ arch = any
+ license = LBNL BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = cppyy-cling
+ depends = python-wheel
+ source = https://files.pythonhosted.org/packages/15/53/b75a3df99aa2a93d32aa7be94672657af9afd80d56a55432baf4ab52cdd7/cppyy-backend-1.10.7.tar.gz
+ sha256sums = 57e7773ce78ee2f22307c5f44f13d203af7b11d001dbe1a0b07f430da4e54b90
+
+pkgname = cppyy-backend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42ff89997f17
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+clean.sh
+instructions.txt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c1b0af55589
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Renato Lui Geh <renatogeh at gmail dot com>
+
+pkgname=cppyy-backend
+pkgver=1.10.7
+pkgrel=1
+pkgdesc="Cling-based Python-C++ bindings (backend)"
+arch=('any')
+url="https://cppyy.readthedocs.io/en/latest/index.html"
+license=('LBNL BSD')
+depends=('python' 'cppyy-cling' 'python-wheel')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/15/53/b75a3df99aa2a93d32aa7be94672657af9afd80d56a55432baf4ab52cdd7/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('57e7773ce78ee2f22307c5f44f13d203af7b11d001dbe1a0b07f430da4e54b90')
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}
+ python3 setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname}-${pkgver}
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+