summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A. Leuenhagen2021-04-22 16:16:50 -0400
committerJohn A. Leuenhagen2021-04-22 16:16:50 -0400
commit17306b0d1156a17b1a4a5a5592b79067de8627f3 (patch)
treee9d69ddf732793c6979ca28e9060fda3bd2bd28f
downloadaur-17306b0d1156a17b1a4a5a5592b79067de8627f3.tar.gz
Initial commit; version 1.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4634925a5aea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cpr
+ pkgdesc = C++ requests library by whoshuu
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/whoshuu/cpr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = curl
+ provides = cpr
+ source = https://github.com/whoshuu/cpr/archive/refs/tags/1.6.0.tar.gz
+ md5sums = c2b074ed245e3e357c4ff0845bb0360a
+
+pkgname = cpr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4a6d10f7cfe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f09d9db2658a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: John A. Leuenhagen <john@zlima12.com>
+
+pkgname=cpr
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="C++ requests library by whoshuu"
+arch=('i686' 'x86_64')
+url="https://github.com/whoshuu/cpr"
+license=('MIT')
+depends=('curl')
+makedepends=('cmake')
+provides=('cpr')
+source=("https://github.com/whoshuu/cpr/archive/refs/tags/$pkgver.tar.gz")
+md5sums=('c2b074ed245e3e357c4ff0845bb0360a')
+
+prepare() {
+ cd "$srcdir/cpr-$pkgver"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCPR_BUILD_TESTS=OFF -DCPR_FORCE_USE_SYSTEM_CURL=ON .
+}
+
+build() {
+ cd "$srcdir/cpr-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/cpr-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib"
+ cp -r lib/libcpr* "$pkgdir/usr/lib"
+
+ mkdir -p "$pkgdir/usr/include"
+ cp -r include/cpr "$pkgdir/usr/include"
+}