summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Backer Dirks2019-08-28 11:25:03 +0100
committerTobias Backer Dirks2019-08-28 11:25:03 +0100
commit25df1ed0b1c01dc80728222c2766b8b505cff9bd (patch)
treeb96ab704bdd0ba25155883e5b2d5c2c0147907ca
parent4fbfdab6ce3d2ed0fb07df3da945174cb05ce9c6 (diff)
downloadaur-25df1ed0b1c01dc80728222c2766b8b505cff9bd.tar.gz
Updated version and PKGBUILD structure.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b47362ca76a..2fa419d2e8f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpr-git
pkgdesc = C++ requests library by whoshuu
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = https://github.com/whoshuu/cpr
arch = i686
@@ -9,7 +9,9 @@ pkgbase = cpr-git
makedepends = git
makedepends = cmake
depends = curl
- source = cpr-1.2::git+https://github.com/whoshuu/cpr.git
+ provides = cpr=1.3
+ conflicts = cpr
+ source = git+https://github.com/whoshuu/cpr
md5sums = SKIP
pkgname = cpr-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..54bd6420478f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+cpr/
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e53a913a4518..08473d1230fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Contributor: Penter ivaiva1999ivaiva@gmail.com
+# Maintainer: Tobias Backer Dirks <omgitsaheadcrab@gmail.com>
+
pkgname=cpr-git
-_pkgname=cpr
+_pkgname="${pkgname%-git}"
_pkgauthor=whoshuu
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="C++ requests library by whoshuu"
arch=('i686' 'x86_64')
@@ -10,19 +11,21 @@ url="https://github.com/whoshuu/cpr"
license=('MIT')
depends=('curl')
makedepends=('git' 'cmake')
+provides=("$_pkgname=${pkgver%%+*}")
+conflicts=("$_pkgname")
+source=("git+$url")
md5sums=('SKIP')
-source+=("${_pkgname}-${pkgver}::git+https://github.com/${_pkgauthor}/${_pkgname}.git")
prepare (){
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
# mkdir build && cd build
cmake -DCPR_LIBRARY=/usr/lib CPR_INCLUDE_DIR=/usr/include -DINSECURE_CURL=ON -DBUILD_CPR_TESTS=OFF -DUSE_SYSTEM_CURL=ON .
make
}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
mkdir "$pkgdir/usr"
cp -R include "$pkgdir/usr"
cp -R lib "$pkgdir/usr"
-}
+} \ No newline at end of file