summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazuki Yamaguchi2021-04-14 04:19:05 +0900
committerKazuki Yamaguchi2021-04-14 04:19:05 +0900
commit8f6246eb192bcb5ba47e58562f8364af9c68fd06 (patch)
treee70d564d9544dd0b9a9cd17760874ae75d4c9d78
parentb4802185c2e9753eecf7ce53c52a52efcfa7cc7a (diff)
downloadaur-8f6246eb192bcb5ba47e58562f8364af9c68fd06.tar.gz
cproto 4.7s
Update to the latest upstream version and fix PKGBUILD style issues. Thanks to dviktor for suggestion.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9bde5f46991..546f0a8f505b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = cproto
- pkgdesc = Cproto is a program that generates function prototypes and variable declarations from C source code.
- pkgver = 4.7o
+ pkgdesc = A program that generates function prototypes and variable declarations from C source code.
+ pkgver = 4.7s
pkgrel = 1
url = http://invisible-island.net/cproto/cproto.html
arch = i686
arch = x86_64
license = custom:public domain
- source = ftp://ftp.invisible-island.net/pub/cproto/cproto-4.7o.tgz
- sha256sums = c76b0b72064e59709459bb7d75d6ec929f77ce5ae7f2610d169ba0fa20ccb44f
+ source = ftp://ftp.invisible-island.net/pub/cproto/cproto-4.7s.tgz
+ sha256sums = 842f28a811f58aa196b77763e08811c2af00472c0ea363d397a545046d623545
pkgname = cproto
diff --git a/PKGBUILD b/PKGBUILD
index 67a9f840922a..2a1f779fcf4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: Kazuki Yamaguchi <k@rhe.jp>
pkgname=cproto
-pkgver=4.7o
+pkgver=4.7s
pkgrel=1
-pkgdesc="Cproto is a program that generates function prototypes and variable declarations from C source code."
+pkgdesc="A program that generates function prototypes and variable declarations from C source code."
arch=('i686' 'x86_64')
url="http://invisible-island.net/cproto/cproto.html"
license=('custom:public domain')
-depends=()
-makedepends=()
-source=("ftp://ftp.invisible-island.net/pub/cproto/cproto-4.7o.tgz")
-sha256sums=('c76b0b72064e59709459bb7d75d6ec929f77ce5ae7f2610d169ba0fa20ccb44f')
+source=("ftp://ftp.invisible-island.net/pub/cproto/cproto-${pkgver}.tgz")
+sha256sums=('842f28a811f58aa196b77763e08811c2af00472c0ea363d397a545046d623545')
build() {
cd "$pkgname-$pkgver"
@@ -25,5 +23,5 @@ check() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
}