summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRikard Falkeborn2015-06-13 10:01:59 +0200
committerRikard Falkeborn2015-06-13 10:01:59 +0200
commit8050baee3ed93d5c19bddfa5a6f9641fe7f60da2 (patch)
tree012addfb0e1c7ce1575d5ae87e15417971a03de2
downloadaur-8050baee3ed93d5c19bddfa5a6f9641fe7f60da2.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e37462da04b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cpu-monitor-extension-lxpanel-plugin
+ pkgdesc = Adds memory and swap usage to the default cpu usage monitor plugin in lxde panel.
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/danamlund/cpu-monitor-extension-lxpanel-plugin
+ arch = i686
+ arch = x86_64
+ groups = lxde
+ license = GPL2
+ depends = lxpanel
+ source = https://github.com/danamlund/cpu-monitor-extension-lxpanel-plugin/archive/v1.5.tar.gz
+ md5sums = babca791069c502b977264c2aa0e6f94
+
+pkgname = cpu-monitor-extension-lxpanel-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67aa87724cde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Rikard Falkeborn <rikard.falkeborn@gmail.com>
+pkgname=cpu-monitor-extension-lxpanel-plugin
+pkgver=1.5
+pkgrel=1
+pkgdesc="Adds memory and swap usage to the default cpu usage monitor plugin in lxde panel."
+arch=('i686' 'x86_64')
+url="https://github.com/danamlund/cpu-monitor-extension-lxpanel-plugin"
+license=('GPL2')
+groups=(lxde)
+depends=('lxpanel')
+source=("https://github.com/danamlund/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('babca791069c502b977264c2aa0e6f94')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/lib/lxpanel/plugins"
+ make DESTDIR="${pkgdir}" install
+}
+