summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXorg2020-05-30 10:48:13 +0200
committerXorg2020-05-30 10:48:13 +0200
commit7aee7384b2a3a7a0f66c2752df1166443cc6474b (patch)
treedc8c16e23ee8c298a08bd9b501561f8090bdaab9
parent8e4a6b080326e6892d5ac182e3b4c60d136f4dd0 (diff)
downloadaur-7aee7384b2a3a7a0f66c2752df1166443cc6474b.tar.gz
Modify PKGBUILD to adhere Arch package guidelines
https://wiki.archlinux.org/index.php/Arch_package_guidelines
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b49b2bb9cf03..bc9c2f7ac7d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = cpu-x-git
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = cmake
makedepends = ninja
makedepends = nasm
diff --git a/PKGBUILD b/PKGBUILD
index b08649b089c1..38d169894466 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@ arch=('i686' 'x86_64')
url="http://X0rg.github.io/CPU-X/"
license=('GPL3')
depends=('gtk3' 'ncurses' 'libcpuid' 'pciutils' 'procps-ng')
-makedepends=('cmake' 'ninja' 'nasm')
+makedepends=('git' 'cmake' 'ninja' 'nasm')
provides=('cpu-x')
conflicts=('cpu-x')
+options=('!strip' 'debug')
source=("git+https://github.com/X0rg/CPU-X.git")
sha512sums=('SKIP')
-options=('!strip' 'debug')
pkgver() {
cd "$_realname"
@@ -22,15 +22,10 @@ pkgver() {
}
build() {
- msg2 "Generate build system..."
cmake -S "$_realname" -B build -GNinja -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr
-
- msg2 "Build..."
cmake --build build
}
package() {
- msg2 "Install..."
DESTDIR="$pkgdir" ninja -C build install
-
}