summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-11-17 14:01:40 -0500
committerJon Gjengset2015-11-17 14:01:40 -0500
commit5910661d46dd81260e6c28935e5cf44cdd80d65c (patch)
tree4c619a7d8edb530f5bd8b78aadc42a83a22a129d
downloadaur-5910661d46dd81260e6c28935e5cf44cdd80d65c.tar.gz
First build
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD35
-rw-r--r--include-time.patch11
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a18a4b9ca51e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cpubars-git
+ pkgdesc = lightweight terminal-based multicore CPU usage monitor
+ pkgver = r27.6deab3e
+ pkgrel = 1
+ url = https://github.com/aclements/cpubars
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = ncurses
+ source = cpubars-git::git+https://github.com/aclements/cpubars.git
+ source = include-time.patch
+ md5sums = SKIP
+ md5sums = 6f6e0e92c6424d5785c901a0d300c7b7
+
+pkgname = cpubars-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..df5d6e2d9558
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c30b1f760a9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
+pkgname=cpubars-git
+pkgver=r27.6deab3e
+pkgrel=1
+pkgdesc="lightweight terminal-based multicore CPU usage monitor"
+arch=('any')
+url="https://github.com/aclements/cpubars"
+license=('MIT')
+depends=('ncurses')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/aclements/cpubars.git" 'include-time.patch')
+md5sums=('SKIP'
+ '6f6e0e92c6424d5785c901a0d300c7b7')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -Np1 -i "${srcdir}/include-time.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make cpubars
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "$srcdir/$pkgname/cpubars" "$pkgdir/usr/bin/cpubars"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/include-time.patch b/include-time.patch
new file mode 100644
index 000000000000..8df5c3b8a0b7
--- /dev/null
+++ b/include-time.patch
@@ -0,0 +1,11 @@
+diff --git a/cpubars.c b/cpubars.c
+index 3acc0d1..223fe42 100644
+--- a/cpubars.c
++++ b/cpubars.c
+@@ -1,5 +1,6 @@
+ // -*- c-file-style: "bsd" -*-
+
++#include <sys/time.h>
+ #include <ctype.h>
+ #include <errno.h>
+ #include <fcntl.h>