summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-03-29 13:57:22 +0000
committerDaniel Bermond2020-03-29 13:57:22 +0000
commit7bc21171f92d758b402348d1f7659188475e9f72 (patch)
tree4a056ab5b93aeedcbe89487f9b500770d3e07f43
downloadaur-7bc21171f92d758b402348d1f7659188475e9f72.tar.gz
Initial commit of cpuid2cpuflags
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffcab194a62d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cpuid2cpuflags
+ pkgdesc = Tool to generate CPU_FLAGS_* for your CPU
+ pkgver = 8
+ pkgrel = 1
+ url = https://github.com/mgorny/cpuid2cpuflags/
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ source = https://github.com/mgorny/cpuid2cpuflags/releases/download/v8/cpuid2cpuflags-8.tar.bz2
+ sha256sums = db8d361e9c2ec7568ec2728b84f92412d482dc78a357e226e2bd747eb97af7a1
+
+pkgname = cpuid2cpuflags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38018e89196c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
+
+pkgname=cpuid2cpuflags
+pkgver=8
+pkgrel=1
+pkgdesc='Tool to generate CPU_FLAGS_* for your CPU'
+arch=('x86_64')
+url='https://github.com/mgorny/cpuid2cpuflags/'
+license=('BSD')
+depends=('glibc')
+source=("https://github.com/mgorny/cpuid2cpuflags/releases/download/v8/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('db8d361e9c2ec7568ec2728b84f92412d482dc78a357e226e2bd747eb97af7a1')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix='/usr'
+ make
+}
+
+check() {
+ make -C "${pkgname}-${pkgver}" check
+}
+
+package() {
+ make -C "${pkgname}-${pkgver}" DESTDIR="$pkgdir" install
+ install -D -m644 "${pkgname}-${pkgver}/COPYING" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}