summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNader Bebawy2019-11-19 13:58:46 +0100
committerNader Bebawy2019-11-19 13:58:46 +0100
commit1f88138399650e91e7ff6de842cfde718415300a (patch)
tree6e3f66149ee89ce64167f4ce87149853c2ca45a9
downloadaur-1f88138399650e91e7ff6de842cfde718415300a.tar.gz
Turbo Boost Version 2.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7076221c3b04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cpumanager-git
+ pkgdesc = CPU controler
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/nbebaw/cpumanager-git
+ arch = any
+ license = GPL
+ depends = zenity
+ source = git+https://github.com/nbebaw/cpumanager-git.git
+ md5sums = SKIP
+
+pkgname = cpumanager-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa06bc2e5a7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=cpumanager-git
+pkgver=2.1
+pkgrel=1
+#epoch=
+pkgdesc="CPU controler"
+arch=('any')
+url="https://github.com/nbebaw/cpumanager-git"
+license=('GPL')
+#groups=()
+depends=(zenity)
+#makedepends=()
+#checkdepends=()
+#optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+#install=
+#changelog=
+source=("git+https://github.com/nbebaw/cpumanager-git.git")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+#build() {
+# cd "$pkgname-$pkgver"
+# ./configure --prefix=/usr
+# make
+#}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ cd "$pkgname"
+ #make DESTDIR="$pkgdir/" install
+ install -Dm755 turbo_boost_v2.1.sh ${pkgdir}/usr/bin/turbo_boost_v2.1 # -> /usr/bin/turbo...
+}