summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormreichardt2016-09-05 15:05:20 +0200
committermreichardt2016-09-05 15:05:20 +0200
commit795f17108756c94409b73ed51a6a130d597aa776 (patch)
treeb2cd9af5bbf3efea15949a94e9e06363d53865c0
downloadaur-795f17108756c94409b73ed51a6a130d597aa776.tar.gz
initial Push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7174af9005a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cpuminer-multi-git
+ pkgdesc = Multi-algo CPUMiner & Reference Cryptonote Miner (JSON-RPC 2.0) - GIT checkout
+ pkgver = v1.2.multi.r15.gf9345a5
+ pkgrel = 1
+ url = https://github.com/tpruvot/cpuminer-multi/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ depends = curl
+ depends = jansson
+ source = git+https://github.com/tpruvot/cpuminer-multi.git
+ md5sums = SKIP
+
+pkgname = cpuminer-multi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..855fd00914c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Milian Reichardt <mreichardt95@gmail.com>
+pkgname=cpuminer-multi-git
+pkgver=v1.2.multi.r15.gf9345a5
+
+pkgver() {
+ cd "cpuminer-multi"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgrel=1
+pkgdesc="Multi-algo CPUMiner & Reference Cryptonote Miner (JSON-RPC 2.0) - GIT checkout"
+arch=('i686' 'x86_64')
+url="https://github.com/tpruvot/cpuminer-multi/"
+license=('GPLv2')
+depends=('curl' 'jansson')
+source=("git+https://github.com/tpruvot/cpuminer-multi.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/cpuminer-multi/"
+ ./autogen.sh
+ ./configure CFLAGS="-march=native" --with-crypto --with-curl
+ make
+}
+
+package() {
+ cd "$srcdir/cpuminer-multi/"
+ make DESTDIR="$pkgdir/" install
+}