summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002018-08-15 11:40:02 +0200
committer0x9fff002018-08-15 11:40:02 +0200
commitc8f0c77d3253ae6b5063217c32112e7b3dba8c72 (patch)
tree1b546161fc9c6f0eef6df238a178062899bae920
downloadaur-c8f0c77d3253ae6b5063217c32112e7b3dba8c72.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7723dc8892a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cpuminer-opt
+ pkgdesc = Optimized multi-algo CPU miner
+ pkgver = 3.8.8.1
+ pkgrel = 1
+ url = https://github.com/JayDDee/cpuminer-opt
+ arch = x86_64
+ license = GPL
+ depends = curl
+ depends = gmp
+ depends = jansson
+ depends = openssl
+ provides = cpuminer
+ provides = cpuminer-multi
+ conflicts = cpuminer
+ conflicts = cpuminer-multi
+ conflicts = cpuminer-multi-git
+ source = cpuminer-opt-3.8.8.1.tar.gz::https://github.com/JayDDee/cpuminer-opt/archive/v3.8.8.1.tar.gz
+ md5sums = bbba91c296b82830adf27db9d696487a
+
+pkgname = cpuminer-opt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..149c9db4b381
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+pkgname=cpuminer-opt
+pkgver=3.8.8.1
+pkgrel=1
+pkgdesc="Optimized multi-algo CPU miner"
+arch=('x86_64')
+url="https://github.com/JayDDee/cpuminer-opt"
+license=('GPL')
+depends=('curl' 'gmp' 'jansson' 'openssl')
+provides=('cpuminer' 'cpuminer-multi')
+conflicts=('cpuminer' 'cpuminer-multi' 'cpuminer-multi-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/JayDDee/cpuminer-opt/archive/v$pkgver.tar.gz")
+md5sums=('bbba91c296b82830adf27db9d696487a')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --with-crypto --with-curl
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}