summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvagnum082020-01-25 20:45:31 +0000
committervagnum082020-01-25 20:45:31 +0000
commit7636474fb2154591b235a20f7b9472c265e2358f (patch)
tree11a7b8a247cfa56428342d3004514f4fd58b481f
parent717ff63389500f616f05a4d07eea95ee7591e899 (diff)
downloadaur-7636474fb2154591b235a20f7b9472c265e2358f.tar.gz
Release v0.8.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--fix-dbus.patch12
3 files changed, 7 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fd20da91731..6421e0b6fb21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpupower-gui
pkgdesc = A GUI utility to set CPU frequency limits
- pkgver = 0.7.2
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/vagnum08/cpupower-gui
arch = any
@@ -16,10 +16,8 @@ pkgbase = cpupower-gui
optdepends = lxsession: needed for authentification in Xfce, LXDE etc.
provides = cpupower-gui
conflicts = cpupower-gui
- source = cpupower-gui_0.7.2.orig.tar.gz::https://github.com/vagnum08/cpupower-gui/archive/v0.7.2.tar.gz
- source = fix-dbus.patch
- sha256sums = 937898269831531f52a05c1cfffa32274971067dbd8ade806d35022e6e5f356f
- sha256sums = f7f2b65596ddaafa5fda63d65bffdb2022e11ed003818fa41ccdb30ca42de418
+ source = cpupower-gui_0.8.0.orig.tar.gz::https://github.com/vagnum08/cpupower-gui/archive/v0.8.0.tar.gz
+ sha256sums = 2c90249a7437f9e565fd12d070719ba97342ab08103f15d4a05ff6081cbbf825
pkgname = cpupower-gui
diff --git a/PKGBUILD b/PKGBUILD
index 12c7d313095c..7a6ad37dbaf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: vagnum08 <vagnum08@gmail.com>
pkgname=cpupower-gui
-pkgver=0.7.2
+pkgver=0.8.0
pkgrel=1
pkgdesc="A GUI utility to set CPU frequency limits"
arch=(any)
@@ -13,20 +13,11 @@ optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
makedepends=('meson')
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("${pkgname}_${pkgver}.orig.tar.gz"::"https://github.com/vagnum08/cpupower-gui/archive/v${pkgver}.tar.gz"
- "fix-dbus.patch")
-sha256sums=('937898269831531f52a05c1cfffa32274971067dbd8ade806d35022e6e5f356f'
- 'f7f2b65596ddaafa5fda63d65bffdb2022e11ed003818fa41ccdb30ca42de418')
-
-prepare() {
- cd "$srcdir/${pkgname}-${pkgver}"
- patch -Np1 -i ../fix-dbus.patch
- # Fix systemd lib path
- sed -i "s@'/lib'@'lib'@" data/services/meson.build
-}
+source=("${pkgname}_${pkgver}.orig.tar.gz"::"https://github.com/vagnum08/cpupower-gui/archive/v${pkgver}.tar.gz")
+sha256sums=('2c90249a7437f9e565fd12d070719ba97342ab08103f15d4a05ff6081cbbf825')
build() {
- meson --prefix /usr --buildtype=plain "$srcdir/${pkgname}-${pkgver}" build
+ meson --prefix /usr -Dsystemddir=/usr/lib/systemd --buildtype=plain "$srcdir/${pkgname}-${pkgver}" build
ninja -C build
}
diff --git a/fix-dbus.patch b/fix-dbus.patch
deleted file mode 100644
index ba47a64350da..000000000000
--- a/fix-dbus.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/cpupower_gui/cpupower-gui-helper.py.in
-+++ b/cpupower_gui/cpupower-gui-helper.py.in
-@@ -229,7 +229,7 @@
- )
- def update_cpu_settings(self, cpu, freq_min_hw, freq_max_hw, governor, sender=None):
- if self._is_authorized(sender):
-- ret = self._update_cpu(cpu, freq_min_hw, freq_max_hw, governor)
-+ ret = self._update_cpu(int(cpu), int(freq_min_hw), int(freq_max_hw), str(governor))
- return ret
- else:
- return -1
-