summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2014-12-20 19:00:16 +0300
committerIvan Shapovalov2014-12-20 19:00:16 +0300
commit11a23164c78896bcbd3fff173442a4785795d7af (patch)
tree08883179b073a5a4d7a19a112640a694c1f00b47
downloadaur-11a23164c78896bcbd3fff173442a4785795d7af.tar.gz
Automated: initialized with version 308-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1663f451d57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cpyrit-cuda-svn
+ pkgdesc = CUDA backend for accelerated attack against WPA-PSK authentication. (SVN version)
+ pkgver = 308
+ pkgrel = 1
+ url = http://code.google.com/p/pyrit/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cuda
+ makedepends = svn
+ depends = pyrit-svn
+ depends = nvidia-utils
+ depends = python2
+ provides = cpyrit-cuda
+ conflicts = cpyrit-calpp-svn
+ conflicts = cpyrit-calpp
+ conflicts = cpyrit-cuda
+ conflicts = cpyrit-opencl
+ source = svn+http://pyrit.googlecode.com/svn/trunk/cpyrit_cuda
+ md5sums = SKIP
+
+pkgname = cpyrit-cuda-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..def686c21d1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ivan Shapovalov <intelfx100@gmail.com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Hoàng Đức Hiếu <hdh@lazny.tang.la>
+# Contributor: Gilfran Ribeiro <contato [at] gilfran [dot] net>
+# Contributor: William Díaz <wdiaz [at] archlinux [dot] us>
+
+pkgname=cpyrit-cuda-svn
+pkgver=308
+pkgrel=1
+pkgdesc="CUDA backend for accelerated attack against WPA-PSK authentication. (SVN version)"
+url="http://code.google.com/p/pyrit/"
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=('pyrit-svn' 'nvidia-utils' 'python2')
+makedepends=('cuda' 'svn')
+conflicts=('cpyrit-calpp-svn' 'cpyrit-calpp' 'cpyrit-cuda' 'cpyrit-opencl')
+provides=('cpyrit-cuda')
+
+source=("svn+http://pyrit.googlecode.com/svn/trunk/cpyrit_cuda")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cpyrit_cuda
+
+ svnversion
+}
+
+build() {
+ cd cpyrit_cuda
+
+ sed "s|' --host-compilation C'||" -i setup.py
+ python2 setup.py build
+}
+
+package() {
+ cd cpyrit_cuda
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}