summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2022-02-25 21:34:52 +0100
committerNichlas Severinsen2022-02-25 21:34:52 +0100
commitbce742af9db09e423aba550b9b9a098b4a3182b1 (patch)
tree885cb871316a1dde00de09f80703c22d1ee482f7
downloadaur-bce742af9db09e423aba550b9b9a098b4a3182b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD43
-rw-r--r--cq-editor.desktop13
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7f8c128d537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cq-editor-bin
+ pkgdesc = CadQuery GUI editor based on PyQT
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/CadQuery/CQ-editor
+ arch = x86_64
+ license = Apache 2.0
+ provides = cq-editor
+ source = https://github.com/CadQuery/CQ-editor/releases/download/0.2/CQ-editor-Linux-x86_64.zip
+ source = https://raw.githubusercontent.com/CadQuery/CQ-editor/master/icons/cadquery_logo_dark.svg
+ source = cq-editor.desktop
+ sha256sums = 9a39fcf938112993290c058c67b1ac92f2560fd459de2f0f94b29a74954df47c
+ sha256sums = 54eca787b08c860682339d28cd3795448118f29f3a7988cdcbc7e671e58cabfa
+ sha256sums = 867b2a5dfaa56aec9a0bdfcd53ae8b857fc4adb1ea15c48b74e351c9a1bfb8c7
+
+pkgname = cq-editor-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..645290056dda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!cq-editor.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ac3d2354b29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Nichlas Severinsen <ns@nsz.no>
+
+pkgname=cq-editor-bin
+_gitname=CQ-editor
+pkgver=0.2
+pkgrel=1
+url="https://github.com/CadQuery/CQ-editor"
+pkgdesc="CadQuery GUI editor based on PyQT"
+provides=("cq-editor")
+arch=("x86_64")
+license=("Apache 2.0")
+
+source=("https://github.com/CadQuery/${_gitname}/releases/download/${pkgver}/${_gitname}-Linux-${arch}.zip"
+ "https://raw.githubusercontent.com/CadQuery/CQ-editor/master/icons/cadquery_logo_dark.svg"
+ "cq-editor.desktop")
+
+sha256sums=("9a39fcf938112993290c058c67b1ac92f2560fd459de2f0f94b29a74954df47c"
+ "54eca787b08c860682339d28cd3795448118f29f3a7988cdcbc7e671e58cabfa"
+ "867b2a5dfaa56aec9a0bdfcd53ae8b857fc4adb1ea15c48b74e351c9a1bfb8c7")
+
+package() {
+ cd $srcdir/${_gitname}
+
+ install -d "${pkgdir}/opt/${pkgname}"
+
+ cp -r . "${pkgdir}/opt/${pkgname}"
+
+ chmod +x "${pkgdir}/opt/${pkgname}/CQ-editor"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+
+ ln -s "${pkgdir}/opt/${pkgname}/CQ-editor" "${pkgdir}/usr/bin/cq-editor"
+
+ # icon for .desktop
+
+ install -Dm644 "${srcdir}/cadquery_logo_dark.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/cq-editor.svg"
+
+ # .desktop
+
+ install -Dm644 "${srcdir}/cq-editor.desktop" "${pkgdir}/usr/share/applications/cq-editor.desktop"
+
+}
+
diff --git a/cq-editor.desktop b/cq-editor.desktop
new file mode 100644
index 000000000000..0199e17f5e1b
--- /dev/null
+++ b/cq-editor.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=v0.2
+Name=CadQuery Editor
+GenericName=CQ Editor
+Comment=CadQuery GUI editor based on PyQT
+Categories=Development;
+Exec=cq-editor
+Icon=cq-editor
+Terminal=false
+Type=Application
+Name[en_US]=CadQuery Editor
+GenericName[en_US]=CQ Editor
+Comment[en_US]=CadQuery GUI editor based on PyQT