summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax2018-12-07 15:26:49 +1100
committerMax2018-12-07 15:26:49 +1100
commitbe9191e82d249b9374b929bd31afe1d3f1265bc1 (patch)
tree7d365784c2ef7dbb1212fbd1e0ae2178268784f3
downloadaur-be9191e82d249b9374b929bd31afe1d3f1265bc1.tar.gz
initial package upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef6a5a2f7173
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cqlsh
+ pkgdesc = CQL shell for apache cassandra
+ pkgver = 3.11.3
+ pkgrel = 1
+ url = https://github.com/apache/cassandra
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ makedepends = cython2
+ depends = python2
+ depends = python2-cassandra-driver
+ source = git+https://github.com/apache/cassandra/#tag=cassandra-3.11.3
+ md5sums = SKIP
+
+pkgname = cqlsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e39a108f7d5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Max Chesterfield <`echo Y2hlc3RtMDA3QGhvdG1haWwuY29tCg== | base64 -d`>
+
+
+pkgname=cqlsh
+pkgdesc="CQL shell for apache cassandra"
+pkgver=3.11.3
+pkgrel=1
+arch=('any')
+license=('Apache')
+depends=('python2' 'python2-cassandra-driver')
+makedepends=('python2-setuptools' 'cython2')
+url="https://github.com/apache/cassandra"
+source=("git+https://github.com/apache/cassandra/#tag=cassandra-$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/cassandra/pylib"
+ python2 setup.py build
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp "$srcdir/cassandra/bin/cqlsh" $pkgdir/usr/bin/cqlsh
+ cp "$srcdir/cassandra/bin/cqlsh.py" $pkgdir/usr/bin/cqlsh
+
+ cd "$srcdir/cassandra/pylib"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}