summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:05:09 +0200
committerChristian Hesse2015-06-28 21:05:09 +0200
commit227029f976f30ac00858ff3023ba92fab820341c (patch)
tree844e798f296a2af412d68908ecd42612553e39e5
downloadaur-227029f976f30ac00858ff3023ba92fab820341c.tar.gz
initial import of cqrlogo 0.5.3-3
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD45
-rw-r--r--cqrlogo.install8
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64f31535794f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = cqrlogo
+ pkgdesc = CGI QR-Code logo for web services
+ pkgver = 0.5.3
+ pkgrel = 3
+ url = https://github.com/eworm-de/cqrlogo
+ install = cqrlogo.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ checkdepends = zbar
+ checkdepends = pngcheck
+ makedepends = fcgi
+ makedepends = markdown
+ depends = iniparser
+ depends = libpng
+ depends = qrencode
+ optdepends = apache: for apache web server inclusion
+ optdepends = fcgi: for FastCGI version
+ optdepends = lighttpd: for lighttpd web server inclusion
+ optdepends = mod_fastcgi: for fastcgi in apache web server
+ optdepends = mod_fcgid: for fastcgi in apache web server
+ conflicts = cqrlogo-git
+ backup = etc/cqrlogo.conf
+ backup = etc/httpd/conf/extra/cqrlogo.conf
+ backup = etc/lighttpd/conf.d/cqrlogo.conf
+ source = http://www.eworm.de/download/cqrlogo/cqrlogo-0.5.3.tar.xz
+ source = http://www.eworm.de/download/cqrlogo/cqrlogo-0.5.3.tar.xz.asc
+ sha256sums = c3d9e3ccdf0a364a2ba980f2e73d4388198439f08e0300372dd29cfe400ea3da
+ sha256sums = SKIP
+
+pkgname = cqrlogo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d226ea1cfd79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=cqrlogo
+pkgver=0.5.3
+pkgrel=3
+pkgdesc="CGI QR-Code logo for web services"
+arch=('i686' 'x86_64')
+url="https://github.com/eworm-de/cqrlogo"
+depends=('iniparser' 'libpng' 'qrencode')
+makedepends=('fcgi' 'markdown')
+optdepends=('apache: for apache web server inclusion'
+ 'fcgi: for FastCGI version'
+ 'lighttpd: for lighttpd web server inclusion'
+ 'mod_fastcgi: for fastcgi in apache web server'
+ 'mod_fcgid: for fastcgi in apache web server')
+conflicts=('cqrlogo-git')
+checkdepends=('zbar' 'pngcheck')
+license=('GPL')
+install=cqrlogo.install
+backup=('etc/cqrlogo.conf'
+ 'etc/httpd/conf/extra/cqrlogo.conf'
+ 'etc/lighttpd/conf.d/cqrlogo.conf')
+validpgpkeys=('BD84DE71F493DF6814B0167254EDC91609BC9183')
+source=("http://www.eworm.de/download/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc})
+sha256sums=('c3d9e3ccdf0a364a2ba980f2e73d4388198439f08e0300372dd29cfe400ea3da'
+ 'SKIP')
+
+build() {
+ cd ${pkgname}-${pkgver}/
+
+ make
+}
+
+check() {
+ cd ${pkgname}-${pkgver}/
+
+ make check
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/cqrlogo.install b/cqrlogo.install
new file mode 100644
index 000000000000..8679a7054533
--- /dev/null
+++ b/cqrlogo.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ' > Configuration files for apache and lighttpd have been installed'
+ echo ' > with this package.'
+ echo ' > For apache make sure mod_alias and either of mod_fastcgi and'
+ echo ' > mod_fcgid is loaded.'
+ echo ' > For lighttpd just include the config file conf.d/cqrlogo.conf'
+ echo ' > in main configuration.'
+}