summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:22:55 +0200
committerChristian Hesse2015-06-28 21:22:55 +0200
commit77398958fd49352284df7d0fceee7125d77a182b (patch)
tree5d43c02bd5f0d8565369d8caf74aa397a5f968e2
downloadaur-77398958fd49352284df7d0fceee7125d77a182b.tar.gz
initial import of cqrlogo-git 0.5.3.r0.g485ef31
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD54
-rw-r--r--cqrlogo.install8
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2297c509049e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = cqrlogo-git
+ pkgdesc = CGI QR-Code logo for web services - git checkout
+ pkgver = 0.5.3.r0.g485ef31
+ pkgrel = 1
+ url = https://github.com/eworm-de/cqrlogo
+ install = cqrlogo.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ checkdepends = zbar
+ checkdepends = pngcheck
+ makedepends = fcgi
+ makedepends = git
+ makedepends = markdown
+ depends = iniparser
+ depends = libpng
+ depends = qrencode
+ optdepends = apache: for apache web server inclusion
+ optdepends = fcgi: for FastCGI version
+ optdepends = lighttpd: for lighttpd web server inclusion
+ optdepends = mod_fastcgi: for fastcgi in apache web server
+ optdepends = mod_fcgid: for fastcgi in apache web server
+ provides = cqrlogo
+ conflicts = cqrlogo
+ backup = etc/cqrlogo.conf
+ backup = etc/httpd/conf/extra/cqrlogo.conf
+ backup = etc/lighttpd/conf.d/cqrlogo.conf
+ source = git://github.com/eworm-de/cqrlogo.git
+ sha256sums = SKIP
+
+pkgname = cqrlogo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb336be25558
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=cqrlogo-git
+pkgver=0.5.3.r0.g485ef31
+pkgrel=1
+pkgdesc="CGI QR-Code logo for web services - git checkout"
+arch=('i686' 'x86_64')
+url="https://github.com/eworm-de/cqrlogo"
+depends=('iniparser' 'libpng' 'qrencode')
+makedepends=('fcgi' 'git' 'markdown')
+optdepends=('apache: for apache web server inclusion'
+ 'fcgi: for FastCGI version'
+ 'lighttpd: for lighttpd web server inclusion'
+ 'mod_fastcgi: for fastcgi in apache web server'
+ 'mod_fcgid: for fastcgi in apache web server')
+conflicts=('cqrlogo')
+provides=('cqrlogo')
+checkdepends=('zbar' 'pngcheck')
+license=('GPL')
+install=cqrlogo.install
+backup=('etc/cqrlogo.conf'
+ 'etc/httpd/conf/extra/cqrlogo.conf'
+ 'etc/lighttpd/conf.d/cqrlogo.conf')
+source=('git://github.com/eworm-de/cqrlogo.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd cqrlogo/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd cqrlogo/
+
+ make
+}
+
+check() {
+ cd cqrlogo/
+
+ make check
+}
+
+package() {
+ cd cqrlogo/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/cqrlogo.install b/cqrlogo.install
new file mode 100644
index 000000000000..8679a7054533
--- /dev/null
+++ b/cqrlogo.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ' > Configuration files for apache and lighttpd have been installed'
+ echo ' > with this package.'
+ echo ' > For apache make sure mod_alias and either of mod_fastcgi and'
+ echo ' > mod_fcgid is loaded.'
+ echo ' > For lighttpd just include the config file conf.d/cqrlogo.conf'
+ echo ' > in main configuration.'
+}