summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Fernández2021-02-08 12:18:04 +0100
committerJavier Fernández2021-02-08 12:18:04 +0100
commit15d7fdb5a22df6a4388002c3bcd325b4335bb534 (patch)
treefa57c1a856cd60a5795870d40ee1a194db5b4fe5
parent8ebf6aef26746ed31b5539fdaee5a6116b15f590 (diff)
downloadaur-15d7fdb5a22df6a4388002c3bcd325b4335bb534.tar.gz
Updated to 7.0.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 301e68b658d7..c72059119cb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = craftbukkit-plugin-worldguard
pkgdesc = plugin providing all the little things (and some big ones), and it protects your servers from various problems.
- pkgver = 6.2.1
+ pkgver = 7.0.4
pkgrel = 1
url = http://enginehub.org/worldguard
arch = any
license = GPLv3
makedepends = dos2unix
depends = craftbukkit>=1.8.1
+ depends = spigot
+ depends = papermc
optdepends = mariadb
- noextract = worldguard-legacy-6.2.1-SNAPSHOT-dist.jar
- source = http://builds.enginehub.org/job/worldguard/9687/download/worldguard-legacy-6.2.1-SNAPSHOT-dist.jar
- md5sums = c30e606fbb70f2ed16555d8dbdce7ad0
+ noextract = worldguard-bukkit-7.0.4.jar
+ source = https://dev.bukkit.org/projects/worldguard/files/3066271/download
+ md5sums = 392e060e34072f3d1c2cc12f619bb9ef
pkgname = craftbukkit-plugin-worldguard
diff --git a/PKGBUILD b/PKGBUILD
index 6f03a35e1bfb..31e062d0d3a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
pkgname=craftbukkit-plugin-worldguard
-pkgver=6.2.1
+pkgver=7.0.4
pkgrel=1
pkgdesc="plugin providing all the little things (and some big ones), and it protects your servers from various problems."
arch=(any)
url="http://enginehub.org/worldguard"
license=("GPLv3")
makedepends=(dos2unix)
-depends=("craftbukkit>=1.8.1")
+depends=("craftbukkit>=1.8.1" "spigot" "papermc")
optdepends=(mariadb)
-source=("http://builds.enginehub.org/job/worldguard/9687/download/worldguard-legacy-$pkgver-SNAPSHOT-dist.jar")
-noextract=("worldguard-legacy-$pkgver-SNAPSHOT-dist.jar")
-md5sums=('c30e606fbb70f2ed16555d8dbdce7ad0')
+source=("https://dev.bukkit.org/projects/worldguard/files/3066271/download")
+noextract=("worldguard-bukkit-$pkgver.jar")
+md5sums=('392e060e34072f3d1c2cc12f619bb9ef')
package() {
- install -Dm644 worldguard-legacy-$pkgver-SNAPSHOT-dist.jar "$pkgdir/srv/craftbukkit/plugins/worldguard-legacy-$pkgver-SNAPSHOT-dist.jar"
- chown craftbukkit:craftbukkit "$pkgdir/srv/craftbukkit/plugins/worldguard-legacy-$pkgver-SNAPSHOT-dist.jar"
+ install -Dm644 worldguard-legacy-$pkgver-SNAPSHOT-dist.jar "$pkgdir/srv/craftbukkit/plugins/worldguard-bukkit-$pkgver.jar"
+ chown craftbukkit:craftbukkit "$pkgdir/srv/craftbukkit/plugins/worldguard-bukkit-$pkgver.jar"
}