summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMCJack1232019-12-16 18:08:45 -0500
committerMCJack1232019-12-16 18:08:45 -0500
commit25215c2e0f6fd5401811b24cd15c83b508e9e5b2 (patch)
treec609292cb4d6a4ee1eaa374930649e45f0472894
downloadaur-25215c2e0f6fd5401811b24cd15c83b508e9e5b2.tar.gz
v2.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58034cf343ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = craftos-pc-ccemux
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/MCJack123/craftos2
+ arch = x86_64
+ arch = i386
+ arch = armv7l
+ arch = aarch64
+ license = MIT
+ depends = craftos-pc>=2.2
+ depends = sdl>=2.0.8
+ source = https://github.com/MCJack123/craftos2/archive/v2.2.tar.gz
+ md5sums = 6aee4aa7a3b74d8e9738f42ded967d4107bb1b6f4eead29b67cf4b5c307112a5
+
+pkgname = craftos-pc-ccemux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..046507dec038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: JackMacWindows <jackmacwindowslinux@gmail.com>
+pkgname=craftos-pc-ccemux
+pkgver=2.2
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=('x86_64' 'i386' 'armv7l' 'aarch64')
+url="https://github.com/MCJack123/craftos2"
+license=('MIT')
+groups=()
+depends=('craftos-pc>=2.2' 'sdl>=2.0.8')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/MCJack123/craftos2/archive/v2.2.tar.gz")
+noextract=()
+md5sums=('6aee4aa7a3b74d8e9738f42ded967d4107bb1b6f4eead29b67cf4b5c307112a5')
+validpgpkeys=()
+
+prepare() {
+ cd "craftos2-$pkgver"
+ make -C craftos2-lua linux
+}
+
+build() {
+ cd "craftos2-$pkgver"
+ ./configure --prefix=/usr
+ make plugin-linux
+}
+
+check() {
+ true
+}
+
+package() {
+ cd "craftos2-$pkgver"
+ install -D -m 0755 ccemux.so "$pkgdir/usr/share/craftos/plugins/ccemux.so"
+}