summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuguste Pop2015-06-11 16:03:39 +0800
committerAuguste Pop2015-06-11 16:07:38 +0800
commiteb94f286b2ef3fde37a53dbe5ff4994a85d14288 (patch)
treec2b0b64c2b7bbd8d48876865b6e0825b2f36f6a2
downloadaur-eb94f286b2ef3fde37a53dbe5ff4994a85d14288.tar.gz
migrate from aur
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
-rw-r--r--copyright45
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d73488a9cbc3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = crafty
+ pkgdesc = A computer chess program
+ pkgver = 24.0
+ pkgrel = 1
+ url = http://www.cis.uab.edu/hyatt/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://www.cis.uab.edu/hyatt/crafty/source/crafty-24.0.zip
+ source = http://www.cis.uab.edu/hyatt/crafty/book/book.bin
+ source = http://www.cis.uab.edu/hyatt/crafty/book/books.bin
+ source = copyright
+ md5sums = 51429d18732e86c80c6ade2af06a92a6
+ md5sums = 6d527840579904bf0e0b0a456a580a9b
+ md5sums = 966a852a2ccd3c32e9167061592928d3
+ md5sums = 438cec9f32fb79f58822f97cf64e7afb
+
+pkgname = crafty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..130a61395d6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Auguste Pop <auguste [at] gmail [dot] com>
+
+pkgname=crafty
+pkgver=24.0
+pkgrel=1
+pkgdesc="A computer chess program"
+arch=('i686' 'x86_64')
+url="http://www.cis.uab.edu/hyatt/"
+license=('custom')
+backup=()
+source=(http://www.cis.uab.edu/hyatt/crafty/source/$pkgname-$pkgver.zip
+ http://www.cis.uab.edu/hyatt/crafty/book/book.bin
+ http://www.cis.uab.edu/hyatt/crafty/book/books.bin
+ copyright)
+md5sums=('51429d18732e86c80c6ade2af06a92a6'
+ '6d527840579904bf0e0b0a456a580a9b'
+ '966a852a2ccd3c32e9167061592928d3'
+ '438cec9f32fb79f58822f97cf64e7afb')
+
+prepare()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's:./runprof:sh ./runprof:' -e \
+ "s:'-DTEST:'-DBOOKDIR=\"\\\\\"/usr/share/crafty\\\\\"\" -DTEST:" \
+ Makefile
+ sed -i 's:"crafty.hlp":BOOKDIR"/crafty.hlp":' option.c
+}
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ unset LDFLAGS
+ make profile
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 crafty "$pkgdir/usr/bin/crafty"
+ install -Dm644 crafty.hlp "$pkgdir/usr/share/crafty/crafty.hlp"
+
+ cd "$srcdir"
+ install -m644 book.bin "$pkgdir/usr/share/crafty/"
+ install -m644 books.bin "$pkgdir/usr/share/crafty/"
+ install -Dm644 copyright "$pkgdir/usr/share/licenses/$pkgname/copyright"
+}
diff --git a/copyright b/copyright
new file mode 100644
index 000000000000..77b5c8434e35
--- /dev/null
+++ b/copyright
@@ -0,0 +1,45 @@
+Crafty, copyright 1996-2010 by Robert M. Hyatt, Ph.D., Associate Professor
+of Computer and Information Sciences, University of Alabama at Birmingham.
+
+Crafty is a team project consisting of the following members. These are
+the people involved in the continuing development of this program, there
+are no particular members responsible for any specific aspect of Crafty.
+
+ Michael Byrne, Pen Argyle, PA.
+ Robert Hyatt, University of Alabama at Birmingham.
+ Tracy Riegle, Hershey, PA.
+ Peter Skinner, Edmonton, AB Canada.
+ Ted Langreck .
+
+All rights reserved. No part of this program may be reproduced in any
+form or by any means, for other than your personal use, without the
+express written permission of the authors. This program may not be used
+in whole, nor in part, to enter any computer chess competition without
+written permission from the authors. Such permission will include the
+requirement that the program be entered under the name "Crafty" so that
+the program's ancestry will be known.
+
+Copies of the source must contain the original copyright notice intact.
+
+Any changes made to this software must also be made public to comply with
+the original intent of this software distribution project. These
+restrictions apply whether the distribution is being done for free or as
+part or all of a commercial product. The authors retain sole ownership
+and copyright on this program except for 'personal use' explained below.
+
+Personal use includes any use you make of the program yourself, either by
+playing games with it yourself, or allowing others to play it on your
+machine, and requires that if others use the program, it must be clearly
+identified as "Crafty" to anyone playing it (on a chess server as one
+example). Personal use does not allow anyone to enter this into a chess
+tournament where other program authors are invited to participate. IE you
+can do your own local tournament, with Crafty + other programs, since this
+is for your personal enjoyment. But you may not enter Crafty into an
+event where it will be in competition with other programs/programmers
+without permission as stated previously.
+
+Crafty is the "son" (direct descendent) of Cray Blitz. it is designed
+totally around the bit-board data structure for reasons of speed of ex-
+ecution, ease of adding new knowledge, and a *significantly* cleaner
+overall design. it is written totally in ANSI C with some few UNIX system
+calls required for I/O, etc.