summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndlessEden2021-09-15 22:34:16 +1000
committerEndlessEden2021-09-15 22:34:16 +1000
commitd8fae723e2b97e302bc8520d36673efedf9b3136 (patch)
tree44f55fda6a99df1d4eeda089966c957445873e4d
parente914da1bbfdfa219f7b2c6fe43c1f8094decb02f (diff)
downloadaur-d8fae723e2b97e302bc8520d36673efedf9b3136.tar.gz
fixing..: bug with craftycontroller.install, debugging still... complains of missing end qoute.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--craftycontroller.install9
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c498e11a0c0..c533f680c85c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,7 +32,7 @@ pkgbase = craftycontroller-git
source = craftycontroller.service
source = start.sh
md5sums = SKIP
- md5sums = 620e11d73a8a0c1822a724280a0988cc
+ md5sums = f18b2c7e59c71dc94b4260c8bd2a2807
md5sums = 2e7d24f5d2982fc6f7ac224378cf2f02
md5sums = 0b6cd32e5c31ed3bb576f5ad652c0db6
diff --git a/PKGBUILD b/PKGBUILD
index d7de25f74368..475dd566e45e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ source=("$_pkgname"::"git+https://gitlab.com/crafty-controller/crafty-web.git"
"$_pkgname.service"
"start.sh")
md5sums=('SKIP'
-'620e11d73a8a0c1822a724280a0988cc'
+'f18b2c7e59c71dc94b4260c8bd2a2807'
'2e7d24f5d2982fc6f7ac224378cf2f02'
'0b6cd32e5c31ed3bb576f5ad652c0db6')
diff --git a/craftycontroller.install b/craftycontroller.install
index 02eb18c2f862..8dccb517508d 100644
--- a/craftycontroller.install
+++ b/craftycontroller.install
@@ -1,9 +1,10 @@
post_install() {
echo "Creating user for Crafty Controller..."
- useradd -M -r -s /bin/bash -b /opt/craftycontroller crafty
+ useradd -M -r -s /bin/bash -b "/opt/craftycontroller" crafty
echo "Setting Permissions..."
- chown -R /opt/craftycontroller crafty:crafty
+ chown -R crafty:crafty "/opt/craftycontroller"
echo "Creating the Python Virtual Enviorment..."
+ cd "/opt/craftycontroller"
python3 -m venv craftycontroller
echo "Warning: About to run first-time Launch!"
echo
@@ -14,12 +15,12 @@ post_install() {
echo "3..."
echo "2..
echo "1."
- sudo -u crafty ./opt/craftycontroller/start.sh && export success=1 & exit 0
+ sudo -u crafty /usr/bin/bash -c /opt/craftycontroller/start.sh && export success=1 & exit 0
if [ ! -z "$success" ]; then
export success="0"
fi
if [ "$success" == "0" ]; then
- echo "Initialisation failed; Please run /opt/craftycontroller/start.sh as 'crafty' user."
+ echo "Initialisation failed, Please run /opt/craftycontroller/start.sh as crafty user."
fi
}