summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-19 07:44:05 +0800
committerzxp198210052024-03-19 07:44:05 +0800
commitb8c60cc5630152ba23e78e2f4c94dc8a164eb568 (patch)
treefe938262708ed41bdc052a9e5fcb79bf9382721a
parent08a7050ca1d8b0f7e78e515f13e72b44a9a3233e (diff)
downloadaur-b8c60cc5630152ba23e78e2f4c94dc8a164eb568.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--crankshaft-client.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a02024b175b..8f6b98284b25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crankshaft-client-bin
pkgdesc = A fast, feature-rich krunker client written in typescript
pkgver = 1.8.0
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/KraXen72/crankshaft
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = crankshaft-client-bin
provides = crankshaft-client=1.8.0
conflicts = crankshaft-client
source = crankshaft-client.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_i686 = crankshaft-client-1.8.0-i686.AppImage::https://github.com/KraXen72/crankshaft/releases/download/1.8.0/crankshaft-portable-linux-i386.AppImage
sha256sums_i686 = e2de6a1520e5385cace8828cc1dba0cb9c301e6c89c3d08f6f0e9dfb914f6c0b
source_x86_64 = crankshaft-client-1.8.0-x86_64.AppImage::https://github.com/KraXen72/crankshaft/releases/download/1.8.0/crankshaft-portable-linux-x86_64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index a9ff6fd9b8ea..6716bfdde964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=crankshaft
pkgname="${_pkgname}-client-bin"
pkgver=1.8.0
_electronversion=10
-pkgrel=8
+pkgrel=9
pkgdesc="A fast, feature-rich krunker client written in typescript"
arch=(
'i686'
@@ -24,13 +24,14 @@ source=(
)
source_i686=("${pkgname%-bin}-${pkgver}-i686.AppImage::${url}/releases/download/${pkgver}/${_pkgname}-portable-linux-i386.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/${pkgver}/${_pkgname}-portable-linux-x86_64.AppImage")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_i686=('e2de6a1520e5385cace8828cc1dba0cb9c301e6c89c3d08f6f0e9dfb914f6c0b')
sha256sums_x86_64=('f6012189d8c76bb08fb6a54a03e2fde6d0c089900f83bc9e661ef015cf5713e7')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
diff --git a/crankshaft-client.sh b/crankshaft-client.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/crankshaft-client.sh
+++ b/crankshaft-client.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file