summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-02-28 11:49:58 +0000
committerPellegrino Prevete2022-02-28 11:49:58 +0000
commit62a22acd03e5c9b97660b659a3e97d200d41b5df (patch)
treee0d5d046ce4f886091406cc6815614755f7e7d9f
downloadaur-62a22acd03e5c9b97660b659a3e97d200d41b5df.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--com.naughtydog.CrashBandicoot2.desktop18
-rw-r--r--com.naughtydog.CrashBandicoot2.pngbin0 -> 403613 bytes
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7970b17896f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = crash-bandicoot-2
+ pkgdesc = PlayStation game.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://en.wikipedia.org/wiki/Crash_Bandicoot_2:_Cortex_Strikes_Back
+ arch = any
+ license = custom
+ depends = duckstation
+ source = SCES-00967.bin::https://archive.org/download/redump.psx/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.zip/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.bin
+ source = SCES-00967.cue::https://archive.org/download/redump.psx/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.zip/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.cue
+ source = com.naughtydog.CrashBandicoot2.desktop
+ source = com.naughtydog.CrashBandicoot2.png
+ sha256sums = 9499b6ad8f0cfdb99ee8ae40bc98776f56fdaa91d01e55448f62aaa2c0df7853
+ sha256sums = 6a4bf93ea6b904303254faa946d877cd705893c17458acb2549606dae586fd98
+ sha256sums = c86c504da065221580a4751abf67da5d5be16bee8daea27806103cc21b91d329
+ sha256sums = 410cf854f85ff43c4720ef5cf01a32d92dddd96890abbbd94193adb83fa78785
+
+pkgname = crash-bandicoot-2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..504a85ee2d29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+_uuid="SCES-00967"
+_app_id="com.naughtydog.CrashBandicoot2"
+pkgname=crash-bandicoot-2
+pkgver=1.0
+pkgrel=1
+pkgdesc="PlayStation game."
+arch=('any')
+url="https://en.wikipedia.org/wiki/Crash_Bandicoot_2:_Cortex_Strikes_Back"
+depends=('duckstation')
+license=("custom")
+_dmca_exemption="https://archive.org/about/dmca.php"
+source=("${_uuid}.bin::https://archive.org/download/redump.psx/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.zip/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.bin"
+ "${_uuid}.cue::https://archive.org/download/redump.psx/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.zip/Crash%20Bandicoot%202%20-%20Cortex%20Strikes%20Back%20%28Europe%29%20%28En%2CFr%2CDe%2CEs%2CIt%29%20%28EDC%29.cue"
+ "${_app_id}.desktop"
+ "${_app_id}.png")
+sha256sums=("9499b6ad8f0cfdb99ee8ae40bc98776f56fdaa91d01e55448f62aaa2c0df7853"
+ "6a4bf93ea6b904303254faa946d877cd705893c17458acb2549606dae586fd98"
+ "c86c504da065221580a4751abf67da5d5be16bee8daea27806103cc21b91d329"
+ "410cf854f85ff43c4720ef5cf01a32d92dddd96890abbbd94193adb83fa78785")
+
+package() {
+ local _game="${pkgdir}/usr/games/${_app_id}"
+ install -Dm755 "${_uuid}.bin" "${_game}/${_uuid}.bin"
+ install -Dm755 "${_uuid}.cue" "${_game}/${_uuid}.cue"
+ install -Dm755 "${_app_id}.desktop" "${pkgdir}/usr/share/applications/${_app_id}.desktop"
+ install -Dm755 "${_app_id}.png" "${pkgdir}/usr/share/icons/${_app_id}.png"
+}
diff --git a/com.naughtydog.CrashBandicoot2.desktop b/com.naughtydog.CrashBandicoot2.desktop
new file mode 100644
index 000000000000..78cefa5f4b4e
--- /dev/null
+++ b/com.naughtydog.CrashBandicoot2.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Name=Crash Bandicoot 2 - Cortex Strikes Back (SCES-00967)
+GenericName=Crash Bandicoot 2
+Comment=Second installment of the Crash Bandicoot franchise for PlayStation.
+Type=Application
+TryExec=duckstation-qt
+Exec=duckstation-qt -fullscreen "/usr/games/com.naughtydog.CrashBandicoot2/SCES-00967.cue"
+Icon=com.naughtydog.CrashBandicoot2
+Categories=Games;
+Terminal=false
+Keywords=Crash
+Actions=preferences;
+
+[Desktop Action preferences]
+Name=Preferences
+Exec=duckstation-qt
+
+X-Desktop-File-Install-Version=0.26
diff --git a/com.naughtydog.CrashBandicoot2.png b/com.naughtydog.CrashBandicoot2.png
new file mode 100644
index 000000000000..c3eb77d09dc0
--- /dev/null
+++ b/com.naughtydog.CrashBandicoot2.png
Binary files differ