summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2021-02-01 20:26:25 -0500
committerAndrew O'Neill2021-02-01 20:26:25 -0500
commit02d4a2c4d7cbff02561fd504df07eab4eb23b386 (patch)
tree081d926e22c95467fbc904d975bd12f6a16d0dda
parent7fd16d8842c799d5ea1888865a76be2ad7173532 (diff)
downloadaur-02d4a2c4d7cbff02561fd504df07eab4eb23b386.tar.gz
Version bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 103d0a8000cb..0c0104931d8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = crate
pkgdesc = Shared nothing, fully searchable, document oriented cluster datastore
- pkgver = 4.3.4
+ pkgver = 4.4.0
pkgrel = 1
url = https://crate.io
install = crate.install
arch = x86_64
license = custom:APACHE
- depends = java-runtime>=11
depends = python
backup = etc/crate/crate.yml
backup = etc/crate/logging.yml
- source = https://cdn.crate.io/downloads/releases/crate-4.3.4.tar.gz
+ source = https://cdn.crate.io/downloads/releases/crate-4.4.0.tar.gz
source = crate.service
source = crate.env
- sha256sums = e0f52314b4a906ad90241f2204725920e04e6dd4a6d2e4f2c0edbafc1c2d9246
+ sha256sums = 92d81d258e0077239bb5ca0215e4b7ee122a87402ae2ae064263d07404293041
sha256sums = 04b36b561498332b1b569e49b42d0bedf04141de07b7b16ff1b06072673cfd21
sha256sums = 6182b8d527d52de4fc80023827518b2e8d873afdda873ef6bd2ed92b91982f75
diff --git a/PKGBUILD b/PKGBUILD
index c49aa5c8e457..c7a0d3ca38f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=crate
-pkgver=4.3.4
+pkgver=4.4.0
pkgrel=1
pkgdesc='Shared nothing, fully searchable, document oriented cluster datastore'
arch=('x86_64')
url='https://crate.io'
license=('custom:APACHE')
-depends=('java-runtime>=11' 'python')
+depends=('python')
install='crate.install'
source=("https://cdn.crate.io/downloads/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.service"
"${pkgname}.env")
-sha256sums=('e0f52314b4a906ad90241f2204725920e04e6dd4a6d2e4f2c0edbafc1c2d9246'
+sha256sums=('92d81d258e0077239bb5ca0215e4b7ee122a87402ae2ae064263d07404293041'
'04b36b561498332b1b569e49b42d0bedf04141de07b7b16ff1b06072673cfd21'
'6182b8d527d52de4fc80023827518b2e8d873afdda873ef6bd2ed92b91982f75')
@@ -26,7 +26,7 @@ package() {
install -dm755 "${pkgdir}/etc/${pkgname}/"
install -dm755 "${pkgdir}/var/log/${pkgname}/"
install -dm755 "${pkgdir}/usr/share/${pkgname}/"
- cp -R bin lib logs plugins "${pkgdir}/usr/share/${pkgname}/"
+ cp -R bin config jdk lib logs plugins "${pkgdir}/usr/share/${pkgname}/"
cp config/* "${pkgdir}/etc/${pkgname}"