summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2015-12-13 13:01:19 +0800
committerGergely Imreh2015-12-13 13:01:19 +0800
commite703651ab963aab64ab1295c374f87743f41116f (patch)
tree048bc7345f5e9b58f2f9127bf5af2fd3c212905d
parentf100a6992ef67e4ad28392b114e7bbb34dafc222 (diff)
downloadaur-e703651ab963aab64ab1295c374f87743f41116f.tar.gz
update to latest version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0779aefb26b4..b33edd192d0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 05:01:05 UTC 2015
pkgbase = crawl-git
- pkgdesc = A modern roguelike game played in the console
- pkgver = 0.17.a0.r1921.g56e792d
+ pkgdesc = Dungeon Crawl Stone Soup, a roguelike adventure through dungeons filled with dangerous monsters in a quest to find the mystifyingly fabulous Orb of Zot.
+ pkgver = 0.18.a0.r775.g4d9e04e
pkgrel = 1
url = http://crawl.develz.org
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = gcc
depends = zlib
depends = ncurses
- source = git+https://github.com/crawl/crawl
+ source = git+https://github.com/crawl/crawl.git
md5sums = SKIP
pkgname = crawl-git
diff --git a/PKGBUILD b/PKGBUILD
index 727bc3ea8a3b..7c45ddd7e6a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
-# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Gergely Imreh <imrehg@gmail.com>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Weston Hanners <weston@hanners.us>
-_pkgname=crawl
pkgname=crawl-git
-pkgver=0.17.a0.r1921.g56e792d
+_pkgname=${pkgname%%-git}
+pkgver=0.18.a0.r775.g4d9e04e
pkgrel=1
-pkgdesc="A modern roguelike game played in the console"
+pkgdesc="Dungeon Crawl Stone Soup, a roguelike adventure through dungeons filled with dangerous monsters in a quest to find the mystifyingly fabulous Orb of Zot."
arch=('i686' 'x86_64')
url="http://crawl.develz.org"
license=('GPL')
depends=('zlib' 'ncurses')
-makedepends=('git')
-source=('git+https://github.com/crawl/crawl')
+makedepends=('git' 'gcc')
+source=('git+https://github.com/crawl/crawl.git')
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $_pkgname
- git submodule init
- git submodule update
+ cd "${_pkgname}"
+ git submodule update --init
}
build() {
- cd "$srcdir"/$_pkgname/$_pkgname-ref/source/
+ cd "${srcdir}/${_pkgname}/${_pkgname}-ref/source/"
make NO_LUA_BINDINGS=Y
}
package() {
- cd "$srcdir"/crawl/crawl-ref/source/
- make prefix=/usr/local/ DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${_pkgname}/${_pkgname}-ref/source/"
+ make prefix=/usr/local/ DESTDIR="${pkgdir}" install
}