summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-11-10 18:38:53 -0500
committerSean Anderson2018-11-10 18:38:53 -0500
commit85b487a5aade2a1f917e1976e70f0a71f4281b9e (patch)
tree0c9fcbf500c6e5edc42b34bb3db38767f7378d51
parent8562dfb8edcb4f8e0b3740353693c75694eb5984 (diff)
downloadaur-85b487a5aade2a1f917e1976e70f0a71f4281b9e.tar.gz
Fix save dir location (thanks derekh)
This should finally ensure crawl saves to the correct location
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dea47e5e5fda..a17916c22f1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crawl-tiles
pkgdesc = Dungeon Crawl Stone Soup with graphical tiles and sound support
pkgver = 0.22.0
- pkgrel = 2
+ pkgrel = 3
url = https://crawl.develz.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index bf424bcd9ab7..3d85c5a35c00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Sean Anderson <seanga2@gmail.com>
# Contributor: Taran Lynn <taranlynn0@gmail.com>
+# Contributor: Derek Hawker <derekhawker+aur@gmail.com>
_srcname=crawl
pkgname=crawl-tiles
pkgver=0.22.0
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="Dungeon Crawl Stone Soup with graphical tiles and sound support"
arch=('i686' 'x86_64')
@@ -28,14 +29,15 @@ source=("https://github.com/crawl/$_srcname/archive/$pkgver.tar.gz")
md5sums=('097b897d53f42f0ed2aff13ff1746738')
getCRAWLOPT() {
- CRAWLOPT="
- prefix=/usr
- bin_prefix=bin
- DESTDIR=$pkgdir
- SAVEDIR='~/.crawl'
- LUA_PACKAGE=lua51
- TILES=y
- SOUND=y"
+ CRAWLOPT=(
+ prefix=/usr
+ bin_prefix=bin
+ DESTDIR=$pkgdir
+ SAVEDIR='~/.crawl'
+ LUA_PACKAGE=lua51
+ TILES=y
+ SOUND=y
+ )
}
prepare() {
@@ -50,7 +52,7 @@ build() {
cd "$_srcname-$pkgver/crawl-ref/source"
getCRAWLOPT
- make $CRAWLOPT
+ make "${CRAWLOPT[@]}"
}
# Tests cannot be run without a debug build.
@@ -66,7 +68,7 @@ package() {
cd "$_srcname-$pkgver/crawl-ref/source"
getCRAWLOPT
- make install $CRAWLOPT
+ make install "${CRAWLOPT[@]}"
# Crawl now creates the save directory in /usr for some reason...
rm -rf $pkgdir/usr/\~/
install -Dm644 "dat/tiles/stone_soup_icon-32x32.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"