summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-08-13 21:24:19 -0400
committerSean Anderson2018-08-13 21:24:19 -0400
commitd3b4142c074b728d04c646c92bd94ae1d40c4418 (patch)
tree8e7c1f3b9de206cf4678d5ba57834a936c5ee73d
parent172b3122bcdb5a0f13b4a8a85e86caf283ebd991 (diff)
downloadaur-d3b4142c074b728d04c646c92bd94ae1d40c4418.tar.gz
Clean up PKGBUILD
-rw-r--r--PKGBUILD42
1 files changed, 12 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33ab9d281e62..73d724dea295 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,3 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Sean Anderson <seanga2@gmail.com>
_srcname=crawl
pkgname=crawl-tiles
@@ -31,39 +26,34 @@ options=()
source=("https://github.com/crawl/$_srcname/archive/$pkgver.tar.gz")
md5sums=('097b897d53f42f0ed2aff13ff1746738')
+CRAWLOPT="
+prefix=/usr
+bin_prefix=bin
+DESTDIR=$pkgdir
+SAVEDIR='~/.crawl'
+LUA_PACKAGE=lua51
+TILES=y
+SOUND=y"
+
prepare() {
gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name "Crawl tiles" --categories "Application;Game" --exec "crawl"
cd "$_srcname-$pkgver/crawl-ref/source"
- echo $_makeflags
echo $pkgver > util/release_ver
}
build() {
cd "$_srcname-$pkgver/crawl-ref/source"
- make \
- prefix=/usr \
- bin_prefix=bin \
- DESTDIR=$pkgdir \
- SAVEDIR='~/.crawl' \
- LUA_PACKAGE=lua51 \
- TILES=y \
- SOUND=y
+ make $CRAWLOPT
}
# Tests cannot be run without a debug build.
# To enable them, add the debug target to build()
#check() {
# cd "$_srcname-$pkgver/crawl-ref/source"
-# make -k test \
-# prefix=/usr \
-# bin_prefix=bin \
-# DESTDIR=$pkgdir \
-# SAVEDIR='~/.crawl' \
-# LUA_PACKAGE=lua51 \
-# TILES=y
+# make -k test $CRAWLOPT
#}
package() {
@@ -71,14 +61,6 @@ package() {
cd "$_srcname-$pkgver/crawl-ref/source"
- make install \
- prefix=/usr \
- bin_prefix=bin \
- DESTDIR=$pkgdir \
- SAVEDIR='~/.crawl' \
- LUA_PACKAGE=lua51 \
- TILES=y \
- SOUND=y
-
+ make install $CRAWLOPT
install -Dm644 "dat/tiles/stone_soup_icon-32x32.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
}