summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÍcar N. S2021-11-11 02:12:31 +0100
committerÍcar N. S2021-11-11 02:12:31 +0100
commit8ccf07c13e30e0f2b77e7da2c7e86968d56168ee (patch)
tree5e8f7edfaf463c870331162a650090bb5da99c26
downloadaur-8ccf07c13e30e0f2b77e7da2c7e86968d56168ee.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..875eb2368e3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = crawley-bin
+ pkgdesc = The unix-way web crawler
+ pkgver = 1.1.4
+ pkgrel = 1
+ url = https://github.com/s0rg/crawley
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ provides = crawley
+ conflicts = crawley
+ conflicts = crawley-git
+ source_x86_64 = crawley-bin-1.1.4-x86_64.tar.gz::https://github.com/s0rg/crawley/releases/download/v1.1.4/crawley_1.1.4_linux_x86_64.tar.gz
+ sha256sums_x86_64 = a6f468289141a63060d1fb08c6784f50514c1d804b79f283e320afc7ba87ace0
+ source_aarch64 = crawley-bin-1.1.4-aarch64.tar.gz::https://github.com/s0rg/crawley/releases/download/v1.1.4/crawley_1.1.4_linux_arm64.tar.gz
+ sha256sums_aarch64 = be0b71d656971d12140010a262de6b7b7ff9568e3921658bbb77f1936e3b84f6
+
+pkgname = crawley-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb711d6cd903
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Ícar N. S. <icar.nin@protonmail.com>
+_name=crawley
+pkgname=$_name-bin
+pkgver=1.1.4
+pkgrel=1
+pkgdesc="The unix-way web crawler"
+arch=(x86_64 aarch64)
+url="https://github.com/s0rg/crawley"
+license=('MIT')
+provides=($_name)
+conflicts=($_name $_name-git)
+source_x86_64=("$pkgname-$pkgver-x86_64.tar.gz::$url/releases/download/v${pkgver}/crawley_${pkgver}_linux_x86_64.tar.gz")
+source_aarch64=("$pkgname-$pkgver-aarch64.tar.gz::$url/releases/download/v${pkgver}/crawley_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('a6f468289141a63060d1fb08c6784f50514c1d804b79f283e320afc7ba87ace0')
+sha256sums_aarch64=('be0b71d656971d12140010a262de6b7b7ff9568e3921658bbb77f1936e3b84f6')
+
+package() {
+ install -Dm775 $_name "$pkgdir"/usr/bin/$_name
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}