summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMustafa Gonul2017-11-19 17:28:40 +0300
committerMustafa Gonul2017-11-19 17:28:40 +0300
commitd111c53da949a9c004811cd378be7b65b1b82d01 (patch)
tree1bb3ba30712b705b6d969825fa9d2678d433aafe
downloadaur-d111c53da949a9c004811cd378be7b65b1b82d01.tar.gz
- Add .SRCINFO
- Add PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09661ce99bf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = create-react-app
+ pkgdesc = Create React apps with no build configuration.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/facebookincubator/create-react-app
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+
+pkgname = create-react-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..899edae130eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: mustafagonul <mustafagonul@gmail..com>
+pkgname=create-react-app
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Create React apps with no build configuration."
+arch=(any)
+url="https://github.com/facebookincubator/create-react-app"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+
+package() {
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+}