summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitrios Vogiatzis2016-10-14 20:12:13 +0000
committerDimitrios Vogiatzis2016-10-14 20:12:13 +0000
commit52cdaec9ed457bb4b304ecd1367e9bf912df3a81 (patch)
tree09d7a8bdf100fd658e9f7f75c66831b90da43540
downloadaur-52cdaec9ed457bb4b304ecd1367e9bf912df3a81.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
-rw-r--r--create_ap-git.install0
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef2d060561da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = create_ap-git
+ pkgdesc = A shell script to create a NATed/Bridged Software Access Point
+ pkgver = r211.64d06fb
+ pkgrel = 1
+ url = https://github.com/oblique/create_ap
+ install = create_ap-git.install
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = bash
+ depends = hostapd
+ depends = iproute2
+ depends = iw
+ depends = dnsmasq
+ depends = iptables
+ depends = util-linux
+ depends = procps-ng
+ optdepends = haveged: boost low entropy
+ backup = usr/lib/systemd/system/create_ap.service
+ source = git+https://github.com/oblique/create_ap
+ sha256sums = SKIP
+
+pkgname = create_ap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35ecd8a1dc72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitrios Vogiatzis <me@dimtree.net>
+# Contributor: Xiaoxiao Pu <i@xiaoxiao.im>
+
+_pkgname=create_ap
+pkgname=${_pkgname}-git
+pkgver=r211.64d06fb
+pkgrel=1
+pkgdesc="A shell script to create a NATed/Bridged Software Access Point"
+arch=('any')
+url="https://github.com/oblique/create_ap"
+license=('BSD')
+depends=('bash' 'hostapd' 'iproute2' 'iw' 'dnsmasq'
+ 'iptables' 'util-linux' 'procps-ng')
+optdepends=('haveged: boost low entropy')
+makedepends=('git')
+backup=('usr/lib/systemd/system/create_ap.service')
+install=create_ap-git.install
+source=("git+https://github.com/oblique/create_ap")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/create_ap"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/create_ap/"
+ install -Dm755 "create_ap" "${pkgdir}/usr/bin/create_ap"
+ install -Dm644 "bash_completion" "${pkgdir}/usr/share/bash-completion/completions/create_ap"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/create_ap/LICENSE"
+ install -Dm644 "create_ap.service" "${pkgdir}/usr/lib/systemd/system/create_ap.service"
+}
diff --git a/create_ap-git.install b/create_ap-git.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/create_ap-git.install