summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitrios Vogiatzis2016-11-11 05:28:29 +0000
committerDimitrios Vogiatzis2016-11-11 05:28:29 +0000
commit7d904d1d17830f782bf34c84a547a891f38126dd (patch)
treea92dd8477d322588cfe05fc91beb50ded65243f8
parenteb2edb7279d45a5ba0e7d40cd9f54305b3fbd175 (diff)
downloadaur-7d904d1d17830f782bf34c84a547a891f38126dd.tar.gz
Use Makefile rather than cherry-picking.
This re-adds '/etc/create_ap.conf', hence the pkgrel bump.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 329f58e2f443..af8aa51c412f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
pkgbase = create_ap-git
pkgdesc = A shell script to create a NATed/Bridged Software Access Point
- pkgver = r211.64d06fb
- pkgrel = 1
+ pkgver = r227.fc28805
+ pkgrel = 2
url = https://github.com/oblique/create_ap
arch = any
license = BSD
makedepends = git
- depends = bash
depends = hostapd
- depends = iproute2
depends = iw
depends = dnsmasq
depends = iptables
- depends = util-linux
- depends = procps-ng
optdepends = haveged: boost low entropy
backup = usr/lib/systemd/system/create_ap.service
- source = git+https://github.com/oblique/create_ap
+ source = create_ap-git::git+https://github.com/oblique/create_ap
sha256sums = SKIP
pkgname = create_ap-git
diff --git a/PKGBUILD b/PKGBUILD
index 98ab4141b268..6f3c1eed4894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=create_ap-git
pkgver=r227.fc28805
-pkgrel=1
+pkgrel=2
pkgdesc="A shell script to create a NATed/Bridged Software Access Point"
arch=('any')
url="https://github.com/oblique/create_ap"
@@ -22,8 +22,6 @@ pkgver() {
package() {
cd "$pkgname"
- install -Dm755 "create_ap" "${pkgdir}/usr/bin/create_ap"
- install -Dm644 "bash_completion" "${pkgdir}/usr/share/bash-completion/completions/create_ap"
+ make DESTDIR="$pkgdir" install
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/create_ap/LICENSE"
- install -Dm644 "create_ap.service" "${pkgdir}/usr/lib/systemd/system/create_ap.service"
}