summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitrios Vogiatzis2016-11-11 05:05:05 +0000
committerDimitrios Vogiatzis2016-11-11 05:08:04 +0000
commiteb2edb7279d45a5ba0e7d40cd9f54305b3fbd175 (patch)
treedceb024a1af3904a33bb1a6845161f8da8cab783
parente9a6a808a17cb5cfa3316f5cbf50dbc9e475c8b7 (diff)
downloadaur-eb2edb7279d45a5ba0e7d40cd9f54305b3fbd175.tar.gz
Refactored to remove redundant variable '_pkgname'
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7668ee931cef..98ab4141b268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Dimitrios Vogiatzis <me@dimtree.net>
# Contributor: Xiaoxiao Pu <i@xiaoxiao.im>
-_pkgname=create_ap
-pkgname=${_pkgname}-git
-pkgver=r211.64d06fb
+pkgname=create_ap-git
+pkgver=r227.fc28805
pkgrel=1
pkgdesc="A shell script to create a NATed/Bridged Software Access Point"
arch=('any')
@@ -13,16 +12,16 @@ depends=('hostapd' 'iw' 'dnsmasq' 'iptables')
optdepends=('haveged: boost low entropy')
makedepends=('git')
backup=('usr/lib/systemd/system/create_ap.service')
-source=("git+https://github.com/oblique/create_ap")
+source=("$pkgname::git+https://github.com/oblique/create_ap")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/create_ap"
+ cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/create_ap/"
+ cd "$pkgname"
install -Dm755 "create_ap" "${pkgdir}/usr/bin/create_ap"
install -Dm644 "bash_completion" "${pkgdir}/usr/share/bash-completion/completions/create_ap"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/create_ap/LICENSE"