summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2016-01-10 19:06:08 -0800
committerPatrick McCarty2016-01-10 19:06:08 -0800
commit4758f9fb0b7d33b581503c5bdb77c98cf496fa33 (patch)
tree603a1b4708d656b450562212a6305c9494bccd86
parent4d0e081337ea9019b1b572d34565dc8df5580256 (diff)
downloadaur-4758f9fb0b7d33b581503c5bdb77c98cf496fa33.tar.gz
Run unit tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 924340e3b1ec..6d009391aeff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Jan 11 02:56:20 UTC 2016
+# Mon Jan 11 03:06:04 UTC 2016
pkgbase = createrepo_c
pkgdesc = A C implementation of createrepo, a tool to create yum repositories
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://fedorahosted.org/createrepo_c/
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = doxygen
+ makedepends = python2-nose
makedepends = python2-sphinx
makedepends = sqlite
makedepends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 71860ddd0957..d4b7caefaacb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=createrepo_c
pkgver=0.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="A C implementation of createrepo, a tool to create yum repositories"
arch=('i686' 'x86_64')
license=('GPL')
url='https://fedorahosted.org/createrepo_c/'
depends=('rpm-org' 'libxml2' 'curl' 'glib2' 'python2')
-makedepends=('cmake' 'doxygen' 'python2-sphinx' 'sqlite' 'zlib')
+makedepends=('cmake' 'doxygen' 'python2-nose' 'python2-sphinx' 'sqlite' 'zlib')
source=("https://github.com/rpm-software-management/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('510d1006294c2cfc7e6e01a5ffa243ac8b8e8cdb045efadfebb5c03f0251adaa')
@@ -32,6 +32,12 @@ build() {
make doc
}
+check() {
+ cd ${pkgname}-${pkgver}
+ make tests
+ make test
+}
+
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install