summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetscoin2018-06-18 05:40:13 -0400
committermetscoin2018-06-18 05:40:13 -0400
commita484e0ec8ba99d7531c7859713c9ea145d27918c (patch)
tree78b1b47e711f9140d259fcc4a577c36128759e39
downloadaur-a484e0ec8ba99d7531c7859713c9ea145d27918c.tar.gz
Init creativecoin-qt repo
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD41
-rw-r--r--boost166.patch60
-rw-r--r--creativecoin-qt.desktop11
-rw-r--r--creativecoin-qt.install11
6 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90e75fdf126b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = creativecoin-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://creativechain.org/
+ install = creativecoin-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = creativecoin
+ source = creativecoin-qt::git+https://github.com/creativechain/creativechain-core.git
+ source = creativecoin-qt.desktop
+ source = boost166.patch
+ sha256sums = SKIP
+ sha256sums = e1f166f658e2234913de9c80f82cbf05259e67bf705aa6f9500def4524045df8
+ sha256sums = f3828f3633d0534efb60399a44b315b155d6bc0105195095d374039e8020164e
+
+pkgname = creativecoin-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b8a54896718
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=creativecoin-qt
+pkgver=1.2.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://creativechain.org/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(creativecoin)
+install=creativecoin-qt.install
+source=("${pkgname%-git}::git+https://github.com/creativechain/creativechain-core.git"
+ "$pkgname.desktop" "boost166.patch")
+sha256sums=('SKIP'
+ 'e1f166f658e2234913de9c80f82cbf05259e67bf705aa6f9500def4524045df8'
+ 'f3828f3633d0534efb60399a44b315b155d6bc0105195095d374039e8020164e'
+ )
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 -i "../boost166.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ find . -type f -iname "*.sh" -exec chmod +x {} \;
+ ./autogen.sh
+ ./configure --with-gui=qt5 --disable-tests
+ make
+}
+
+
+package() {
+ install -Dm644 creativecoin-qt.desktop "$pkgdir"/usr/share/applications/creativecoin.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/creativecoin-qt "$pkgdir"/usr/bin/creativecoin-qt
+ install -Dm644 share/pixmaps/bitcoin128.png "$pkgdir"/usr/share/pixmaps/creativecoin128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/boost166.patch b/boost166.patch
new file mode 100644
index 000000000000..f747874d829e
--- /dev/null
+++ b/boost166.patch
@@ -0,0 +1,60 @@
+diff '--color=auto' -Nura creativecoin-qt.orig/src/miner.h creativecoin-qt.new/src/miner.h
+--- creativecoin-qt.orig/src/miner.h 2018-06-18 05:14:51.437350564 -0400
++++ creativecoin-qt.new/src/miner.h 2018-06-18 05:16:34.102085644 -0400
+@@ -73,7 +73,7 @@
+ // except operating on CTxMemPoolModifiedEntry.
+ // TODO: refactor to avoid duplication of this logic.
+ struct CompareModifiedEntry {
+- bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b)
++ bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b) const
+ {
+ double f1 = (double)a.nModFeesWithAncestors * b.nSizeWithAncestors;
+ double f2 = (double)b.nModFeesWithAncestors * a.nSizeWithAncestors;
+diff '--color=auto' -Nura creativecoin-qt.orig/src/txmempool.h creativecoin-qt.new/src/txmempool.h
+--- creativecoin-qt.orig/src/txmempool.h 2018-06-18 05:14:51.987356993 -0400
++++ creativecoin-qt.new/src/txmempool.h 2018-06-18 05:19:27.541190334 -0400
+@@ -229,7 +229,7 @@
+ class CompareTxMemPoolEntryByDescendantScore
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ bool fUseADescendants = UseDescendantScore(a);
+ bool fUseBDescendants = UseDescendantScore(b);
+@@ -251,7 +251,7 @@
+ }
+
+ // Calculate which score to use for an entry (avoiding division).
+- bool UseDescendantScore(const CTxMemPoolEntry &a)
++ bool UseDescendantScore(const CTxMemPoolEntry &a) const
+ {
+ double f1 = (double)a.GetModifiedFee() * a.GetSizeWithDescendants();
+ double f2 = (double)a.GetModFeesWithDescendants() * a.GetTxSize();
+@@ -266,7 +266,7 @@
+ class CompareTxMemPoolEntryByScore
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ double f1 = (double)a.GetModifiedFee() * b.GetTxSize();
+ double f2 = (double)b.GetModifiedFee() * a.GetTxSize();
+@@ -280,7 +280,7 @@
+ class CompareTxMemPoolEntryByEntryTime
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ return a.GetTime() < b.GetTime();
+ }
+@@ -289,7 +289,7 @@
+ class CompareTxMemPoolEntryByAncestorFee
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ double aFees = a.GetModFeesWithAncestors();
+ double aSize = a.GetSizeWithAncestors();
diff --git a/creativecoin-qt.desktop b/creativecoin-qt.desktop
new file mode 100644
index 000000000000..1323fa6e5805
--- /dev/null
+++ b/creativecoin-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Creativecoin
+Comment=Creativecoin P2P Cryptocurrency
+Exec=/usr/bin/creativecoin-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/creativecoin128.png
+MimeType=x-scheme-handler/creativecoin;
+Categories=Office;
+Name[en_US]=creativecoin-qt.desktop
diff --git a/creativecoin-qt.install b/creativecoin-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/creativecoin-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}