summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2020-12-28 14:56:34 -0600
committerHurricanePootis2020-12-28 14:56:34 -0600
commit0dabba6ce067b3cdcb802050e73467c07a2c272b (patch)
treeb33c824da622392418cc1ac1286e6ce5bd5f77b7
downloadaur-0dabba6ce067b3cdcb802050e73467c07a2c272b.tar.gz
Move my old stuff to new repo :|
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d895d7d38c2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = creators-tf-launcher-bin
+ pkgdesc = The community launcher from the Creators.TF project for Team Fortress 2
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://creators.tf/launcher
+ arch = x86_64
+ license = MIT
+ depends = libnotify
+ depends = libxss
+ depends = nspr
+ depends = nss
+ depends = gtk3
+ source = https://github.com/ampersoftware/Creators.TF-Community-Launcher/releases/download/v0.2.1/creators-tf-launcher_0.2.1_amd64.deb
+ md5sums = dd0b6cd88804c0e977ef63ccd5ca0107
+
+pkgname = creators-tf-launcher-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ced56a99c89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=creators-tf-launcher-bin
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="The community launcher from the Creators.TF project for Team Fortress 2"
+arch=(x86_64)
+url="https://creators.tf/launcher"
+license=('MIT')
+depends=('libnotify' 'libxss' 'nspr' 'nss' 'gtk3')
+source=("https://github.com/ampersoftware/Creators.TF-Community-Launcher/releases/download/v$pkgver/creators-tf-launcher_"$pkgver"_amd64.deb")
+md5sums=('dd0b6cd88804c0e977ef63ccd5ca0107')
+
+prepare() {
+ tar xpf data.tar.xz
+}
+
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/opt/Creators.TF Launcher"
+ cp -a "$srcdir/opt/Creators.TF Launcher/." "$pkgdir/opt/Creators.TF Launcher"
+
+ install -Dm644 "${srcdir}/usr/share/applications/creators-tf-launcher.desktop" \
+ "${pkgdir}/usr/share/applications/creators-tf-launcher.desktop"
+
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/creators-tf-launcher.png" \
+ "${pkgdir}/usr/share/icons/hicolor/symbolic/apps/creators-tf-launcher.png"
+
+
+
+}
+