summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuint Guvernator2015-07-13 11:51:43 -0400
committerQuint Guvernator2015-07-13 11:51:43 -0400
commit191f955d14f202080726660ecdf6b01c9ab5d3b5 (patch)
treed5c097ddf48e25971d6954056ddb52f32c0b27ab
downloadaur-191f955d14f202080726660ecdf6b01c9ab5d3b5.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de74ee561104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = creddit-git
+ pkgdesc = CLI Reddit client written in C.
+ pkgver = r177.accd51f
+ pkgrel = 1
+ url = https://github.com/Cotix/cReddit
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ depends = ncurses
+ depends = curl
+ provides = creddit-git
+ conflicts = creddit-git
+ source = creddit-git::git+http://github.com/Cotix/cReddit.git
+ md5sums = SKIP
+
+pkgname = creddit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a0c01e308f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Quint Guvernator <quint@guvernator.net>
+
+pkgname="creddit-git"
+pkgver=r177.accd51f
+pkgrel=1
+pkgdesc='CLI Reddit client written in C.'
+arch=('x86_64' 'i686')
+url='https://github.com/Cotix/cReddit'
+license=('MIT')
+depends=('ncurses' 'curl')
+makedepends=('git' 'make' 'gcc')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname::git+http://github.com/Cotix/cReddit.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr/" install
+}