diff options
author | Quint Guvernator | 2021-12-29 08:52:42 -0500 |
---|---|---|
committer | Quint Guvernator | 2021-12-29 09:07:14 -0500 |
commit | afd7e53e0ea38e907ddf359722d356b435d8bbab (patch) | |
tree | b368e62361158ea484807c394706e27a7e6488e0 | |
parent | 2aa1b07ffac4f5ea739823d450bd142a05c3fe59 (diff) | |
download | aur-afd7e53e0ea3.tar.gz |
use -git suffix only for AUR package name
-rw-r--r-- | .SRCINFO | 10 | ||||
-rw-r--r-- | 01-ncursesw-is-default-ncurses.patch | 6 | ||||
-rw-r--r-- | PKGBUILD | 22 |
3 files changed, 21 insertions, 17 deletions
@@ -1,7 +1,7 @@ pkgbase = creddit-git pkgdesc = CLI Reddit client written in C. pkgver = r214.aa129b9c9b2a - pkgrel = 1 + pkgrel = 2 url = https://github.com/Cotix/cReddit arch = x86_64 arch = i686 @@ -9,11 +9,11 @@ pkgbase = creddit-git makedepends = git depends = ncurses depends = curl - provides = creddit-git - conflicts = creddit-git - source = creddit-git::git+https://github.com/Cotix/cReddit.git + provides = creddit + conflicts = creddit + source = creddit::git+https://github.com/Cotix/cReddit.git source = 01-ncursesw-is-default-ncurses.patch md5sums = SKIP - md5sums = 9b475cc98d0319356772d8472b602c67 + md5sums = f61218a4235e342f7b094d8aac189683 pkgname = creddit-git diff --git a/01-ncursesw-is-default-ncurses.patch b/01-ncursesw-is-default-ncurses.patch index 9f980f7fcb4..8a3a5c0f368 100644 --- a/01-ncursesw-is-default-ncurses.patch +++ b/01-ncursesw-is-default-ncurses.patch @@ -1,7 +1,7 @@ -diff --git a/creddit-git/src/creddit.mk b/creddit-git/src/creddit.mk +diff --git a/src/creddit.mk b/src/creddit.mk index de8710c3659e..c5435a75831a 100644 ---- a/creddit-git/src/creddit.mk -+++ b/creddit-git/src/creddit.mk +--- a/src/creddit.mk ++++ b/src/creddit.mk @@ -5,7 +5,6 @@ ifdef F_MACOSX CREDDIT_LDFLAGS+=-lncurses else @@ -1,39 +1,43 @@ # Maintainer: Quint Guvernator <quint@guvernator.net> -pkgname="creddit-git" +_pkgname=creddit +pkgname=creddit-git pkgver=r214.aa129b9c9b2a -pkgrel=1 +pkgrel=2 pkgdesc='CLI Reddit client written in C.' arch=('x86_64' 'i686') url='https://github.com/Cotix/cReddit' license=('MIT') depends=('ncurses' 'curl') makedepends=('git') -provides=("$pkgname") -conflicts=("$pkgname") +provides=("$_pkgname") +conflicts=("$_pkgname") source=( - "$pkgname::git+https://github.com/Cotix/cReddit.git" + "$_pkgname::git+https://github.com/Cotix/cReddit.git" '01-ncursesw-is-default-ncurses.patch' ) md5sums=('SKIP' - '9b475cc98d0319356772d8472b602c67') + 'f61218a4235e342f7b094d8aac189683') prepare() { + cd "$_pkgname" + # patch the location of the ncursesw library patch -p1 -i "$srcdir/01-ncursesw-is-default-ncurses.patch" } pkgver() { - cd "$pkgname" + cd "$_pkgname" printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } build() { - cd "$pkgname" + cd "$_pkgname" make } package() { - cd "$pkgname" + cd "$_pkgname" + install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE" make PREFIX="$pkgdir/usr/" install } |