summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author/dev/rs02015-07-06 11:51:12 -0500
committer/dev/rs02015-07-06 11:51:12 -0500
commite8810954d4ff78f500c89f7bdf7581f277752bf8 (patch)
treeae9d58c53b7c63e5c7f2a088807bb42810a388cb
downloadaur-e8810954d4ff78f500c89f7bdf7581f277752bf8.tar.gz
Initial import of version 0.3-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e7087ae157e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = creddump-svn
+ pkgdesc = Extracts credentials from Windows registry hives.
+ pkgver = 2
+ pkgrel = 1
+ url = https://code.google.com/p/creddump
+ arch = any
+ license = BSD
+ makedepends = svn
+ depends = python2
+ source = svn+http://creddump.googlecode.com/svn/trunk
+ md5sums = SKIP
+
+pkgname = creddump-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..620efe759e0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: /dev/rs0 <rs0@secretco.de.com>
+
+pkgname=creddump-git
+pkgver=r10.3df4a14
+pkgrel=1
+pkgdesc="Extracts credentials from Windows registry hives."
+
+arch=('any')
+url="https://github.com/Neohapsis/creddump7"
+license=('GPL3')
+
+replaces=('creddump')
+conflicts=('creddump')
+provides=('creddump=0.3')
+
+makedepends=('git')
+depends=('python2' 'python2-crypto')
+
+source=("creddump::git+https://github.com/Neohapsis/creddump7.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "creddump"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "creddump"
+
+ install -d "${pkgdir}/usr/share/licenses/creddump"
+ install -Dm0644 "COPYING" "${pkgdir}/usr/share/licenses/creddump/LICENSE"
+
+ rm CHANGELOG COPYING
+
+ install -d "${pkgdir}/usr/share/creddump"
+ cp -a . "${pkgdir}/usr/share/creddump"
+
+ install -d "${pkgdir}/usr/bin"
+ for file in *.py; do
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' "$file"
+ install -Dm0755 "$file" "${pkgdir}/usr/share/creddump"
+ ln -s "/usr/share/creddump/${file}" "${pkgdir}/usr/bin/${file%.*}"
+ done
+}