summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Minshall2023-01-03 11:28:47 +0300
committerGreg Minshall2023-01-03 11:28:47 +0300
commit9b9fa12e64ba9b232ee6e910bfde6d0ef5735658 (patch)
treeaa681ad7e6eed9480a28340ca7416ab2675b3409
downloadaur-9b9fa12e64ba9b232ee6e910bfde6d0ef5735658.tar.gz
copy template from ../orgtbl-query; customize
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634620c254eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = orgtbl-query
+ pkgdesc = query the contents of emacs org-mode tables in files
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://sr.ht/~minshall/orgtbl-query/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = gawk
+ optdepends = emacs: create and operate on org-mode files
+ source = git+https://git.sr.ht/~minshall/orgtbl-query#tag=b44cd466efc3d98f659a2d4dc3ce6cc1aac9299d?signed
+ validpgpkeys = BB68C8D3A3D23B9B398FB50AC397C74C54A9EC4F
+ sha256sums = SKIP
+
+pkgname = orgtbl-query
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..947c08a46907
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Greg Minshall <minshall at umich dot edu>
+pkgname=credeface
+pkgver=1.2.9
+pkgrel=1
+pkgdesc="use git’s credential-cache to hold general passwords"
+arch=(any)
+url="https://sr.ht/~minshall/credeface/"
+license=('MIT')
+depends=(git python3)
+makedepends=(gawk git asciidoc)
+optdepends=('emacs: create and operate on org-mode files')
+# git rev-parse 1.2.9 (in upstream repo)
+_tag=c1551195124b8576a697c7e663b59886474f5791
+source=(git+https://git.sr.ht/~minshall/credeface#tag=${_tag}?signed)
+validpgpkeys=(
+ BB68C8D3A3D23B9B398FB50AC397C74C54A9EC4F # Greg Minshall <minshall@acm.org>
+)
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "${pkgname}"
+ git describe
+}
+
+build() {
+ cd "${pkgname}"
+
+ make
+}
+
+# sadly, no check()
+
+package() {
+ cd "${pkgname}"
+
+ echo PKGDIR "${pkgdir}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ # install our MIT license
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}